diff mbox series

bug#67760: Add the guile-srfi-232 package for curried procedures

Message ID 87v887eoht.fsf@gnu.org
State New
Headers show
Series bug#67760: Add the guile-srfi-232 package for curried procedures | expand

Commit Message

Ludovic Courtès Jan. 5, 2024, 4:25 p.m. UTC
Hi,

無無 <yuvallangerontheroad@gmail.com> skribis:

> From c88c0502b2036c7a33fcb9c402de69eb14634831 Mon Sep 17 00:00:00 2001
> Message-Id: <c88c0502b2036c7a33fcb9c402de69eb14634831.1702256938.git.yuval.langer@gmail.com>
> From: Yuval Langer <yuval.langer@gmail.com>
> Date: Mon, 11 Dec 2023 03:00:50 +0200
> Subject: [PATCH] Add the guile-srfi-232 package for curried procedures.
>
> ---
>  gnu/packages/guile-xyz.scm | 51 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 51 insertions(+)

Applied with the changes below, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 6df9fc851f..75e3754046 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3858,8 +3858,7 @@  (define-public guile-srfi-232
     (arguments
      (list
       #:phases
-      #~(modify-phases
-            %standard-phases
+      #~(modify-phases %standard-phases
           (add-after 'unpack 'move-and-delete-things
             (lambda _
               (let* ((srfi-directory (string-append #$output "/srfi")))
@@ -3881,14 +3880,14 @@  (define-public guile-srfi-232
     (home-page "https://github.com/scheme-requests-for-implementation/srfi-232")
     (synopsis "Flexible curried procedures")
     (description
-     "Scheme lacks a flexible way to create and apply curried
-procedures.  This SRFI describes curried, a variant of lambda that
-creates true curried procedures which also behave just like ordinary
-Scheme procedures.  They can be applied to their arguments one by one,
-all at once, or anywhere in between, without any novel syntax.
-curried also supports nullary and variadic procedures, and procedures
-created with it have predictable behavior when applied to surplus
-arguments.")
+     " This package provides an implementation of
+@uref{https://srfi.schemers.org/srfi-232/srfi-232.html, SRFI-232}, which
+describes @code{curried}, a variant of @code{lambda} that creates true curried
+procedures which also behave just like ordinary Scheme procedures.  They can
+be applied to their arguments one by one, all at once, or anywhere in between,
+without any novel syntax.  @code{curried} also supports nullary and variadic
+procedures, and procedures created with it have predictable behavior when
+applied to surplus arguments.")
     (license license:expat)))
 
 (define-public emacsy