diff mbox series

[bug#69403,2/2] gnu: go-github-com-signintech-gopdf: Remove examples.

Message ID 87v86b8uvd.fsf@troyfigiel.com
State New
Headers show
Series gnu: go-github-com-signintech-gopdf: Remove examples. | expand

Commit Message

Troy Figiel Feb. 26, 2024, 7:51 a.m. UTC
* gnu/packages/golang.scm (go-github-com-signintech-gopdf): Remove examples.
[arguments] <#:phases>: Add remove-examples phase.
---
 gnu/packages/golang.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ac500b58af..609a14ec61 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2250,7 +2250,14 @@  (define-public go-github-com-signintech-gopdf
                 "1h6cslvid5v8fiymydj4irrzi8f91knsx8rgbzp2b8favclhwxxg"))))
     (build-system go-build-system)
     (arguments
-     '(#:import-path "github.com/signintech/gopdf"))
+     (list
+      #:import-path "github.com/signintech/gopdf"
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'remove-examples
+                     (lambda* (#:key import-path #:allow-other-keys)
+                       (delete-file-recursively (string-append "src/"
+                                                               import-path
+                                                               "/examples")))))))
     (propagated-inputs (list go-github-com-pkg-errors
                              go-github-com-phpdave11-gofpdi))
     (home-page "https://github.com/signintech/gopdf")