diff mbox series

[bug#72037] gnu: Add python-svgelements.

Message ID 87v81d47bt.fsf@pisemsky.site
State New
Headers show
Series [bug#72037] gnu: Add python-svgelements. | expand

Commit Message

Evgeny Pisemsky July 10, 2024, 3:04 p.m. UTC

diff mbox series

Patch

From 1a0dad5f3e21f1e1da09c0adeb6e645af252519c Mon Sep 17 00:00:00 2001
Message-ID: <1a0dad5f3e21f1e1da09c0adeb6e645af252519c.1720623721.git.mail@pisemsky.site>
From: Evgeny Pisemsky <mail@pisemsky.site>
Date: Wed, 10 Jul 2024 18:00:06 +0300
Subject: [PATCH] gnu: Add python-svgelements.

* gnu/packages/python-xyz.scm (python-svgelements): New variable.

Change-Id: Ief5aa396d2073b1235f5bd742343e38a588bd086
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 93eeab8ea9..49a9e98de4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -153,6 +153,7 @@ 
 ;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
 ;;; Copyright © 2024 TakeV <takev@disroot.org>
 ;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
+;;; Copyright © 2024 Evgeny Pisemsky <mail@pisemsky.site>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -31735,6 +31736,26 @@  (define-public python-jinxed
      "Jinxed is an implementation of a subset of the Python curses library.")
     (license license:mpl2.0)))
 
+(define-public python-svgelements
+  (package
+    (name "python-svgelements")
+    (version "1.9.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "svgelements" version))
+       (sha256
+        (base32 "1xrp7yxg65dqdrmghriljf9hh2smq2zhzr2hzmqifgfd0ijas0kw"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-scipy python-numpy python-pillow))
+    (home-page "https://github.com/meerk40t/svgelements")
+    (synopsis "SVG parsing for elements, paths, and other SVG objects")
+    (description
+     "This module does high fidelity SVG parsing and geometric rendering.
+The goal is to successfully and correctly process SVG for use with any
+scripts that may need or want to use SVG files as geometric data.")
+    (license license:expat)))
+
 (define-public python-svgutils
   (package
     (name "python-svgutils")

base-commit: 71694363f6cc79e44955acbd9f7ca108e658caca
-- 
2.45.2