[bug#72416] gnu: usbrelay: Update to 1.2.1.
Commit Message
Comments
I successfully tested the patch with a real relay, including udev rules.
From 523d0096745e8e649b966101f528b402ec06fc48 Mon Sep 17 00:00:00 2001
Message-ID: <523d0096745e8e649b966101f528b402ec06fc48.1722586951.git.mail@pisemsky.site>
From: Evgeny Pisemsky <mail@pisemsky.site>
Date: Fri, 2 Aug 2024 11:00:11 +0300
Subject: [PATCH] gnu: usbrelay: Update to 1.2.1.
* gnu/packages/hardware.scm (usbrelay): Update to 1.2.1.
Change-Id: I5b889889c528d5526c8cfcc66d56b2b9d8d60437
---
gnu/packages/hardware.scm | 38 +++++++++++++++++++++++---------------
1 file changed, 23 insertions(+), 15 deletions(-)
@@ -1580,28 +1580,36 @@ (define-public lxi-tools
(define-public usbrelay
(package
(name "usbrelay")
- (version "1.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/darrylb123/usbrelay")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0fr3wglr2c6myg4k6ai2p5z38prclcnk2ngik15sq16fnp6qg750"))))
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/darrylb123/usbrelay")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xw2fqx4drmkvv587vkz3aicp6pw1mzxr8bjz8wad9j4c0r24cgn"))))
(build-system gnu-build-system)
(arguments
(list
#:phases #~(modify-phases %standard-phases
- (delete 'configure)) ;no configure script
- #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
- (string-append "PREFIX=" #$output)
+ ;; No configure script.
+ (delete 'configure)
+ (add-after 'install 'install-manpage
+ (lambda _
+ (install-file "usbrelay.1"
+ (string-append #$output "/share/man/man1")))))
+ #:make-flags #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target))
(string-append "LDFLAGS=-Wl,-rpath="
(string-append #$output "/lib"))
"LDCONFIG=true"
- "USBMAJOR=$(USBLIBVER)")
- #:tests? #f)) ;no test suite
+ (string-append "USBMAJOR=" #$version)
+ (string-append "USBLIBVER=" #$version)
+ (string-append "VERSION=" #$version))
+ ;; No test suite.
+ #:tests? #f))
(inputs (list hidapi))
(home-page "https://github.com/darrylb123/usbrelay")
(synopsis "Control USB relay modules")
base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8
--
2.45.2