[bug#33920] gnu: gauche: Update to 0.9.7 - removed html doc.

Message ID 87tvi9ugup.fsf@gmail.com
State Accepted
Headers show
Series [bug#33920] gnu: gauche: Update to 0.9.7 - removed html doc. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Gabriel Hondet Jan. 16, 2019, 8:49 a.m. UTC
On Tue 15 Jan 2019 at 18:34 Ludovic Courtès wrote:

> Regarding documentation:
>
>> +         (add-after 'build 'build-doc
>> +           (lambda* (#:key outputs #:allow-other-keys)
>> +             (let* ((out (assoc-ref outputs "out")))
>> +               (with-directory-excursion "doc"
>> +                 (for-each
>> +                  (lambda (target)
>> +                    (invoke "make" target))
>> +                  '("info" "html" "htmls"))))
>
> I left it as is but normally we provide only Info (for packages that
> come with Texinfo manuals.)  Would you be OK removing the HTML bits?

Here you are,

* gnu/packages/scheme.scm (gauche): Update to 0.9.7 - removed html doc.
---
 gnu/packages/scheme.scm | 17 ++++++-----------
 1 file changed, 6 insertions(+), 11 deletions(-)

Patch

diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 48b52c7da..9cc190b51 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1213,13 +1213,9 @@  The core is 12 builtin special forms and 33 builtin functions.")
                (("/bin/sh") (which "sh")))
              #t))
          (add-after 'build 'build-doc
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out")))
-               (with-directory-excursion "doc"
-                 (for-each
-                  (lambda (target)
-                    (invoke "make" target))
-                  '("info" "html" "htmls"))))
+           (lambda* _
+             (with-directory-excursion "doc"
+               (invoke "make" "info"))
              #t))
          (add-before 'check 'patch-normalize-test
            ;; neutralize sys-normalize-pathname test as it relies on
@@ -1235,10 +1231,9 @@  The core is 12 builtin special forms and 33 builtin functions.")
                (("binary net termios") "binary termios"))
              #t))
          (add-after 'install 'install-docs
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out")))
-               (with-directory-excursion "doc"
-                 (invoke "make" "install")))
+           (lambda* _
+             (with-directory-excursion "doc"
+               (invoke "make" "install"))
              #t)))))
     (synopsis "Scheme scripting engine")
     (description "Gauche is a R7RS Scheme scripting engine aiming at being a