bug#34912: [PATCH] gnu: Add xl2tpd.

Message ID 87tvfu1t56.fsf@gnu.org
State Accepted
Headers show
Series bug#34912: [PATCH] gnu: Add xl2tpd. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Ludovic Courtès March 22, 2019, 9:44 p.m. UTC
Hi Tomáš,

Tomáš Čech <sleep_walker@gnu.org> skribis:

> * gnu/packages/vpn.scm (xl2tpd): New variable.

Applied with the changes below to placate ‘guix lint’.

Thanks,
Ludo’.

Patch

diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 88fd9e142d..e164d9aa4c 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -524,12 +524,14 @@  WireGuard support.")
     (name "xl2tpd")
     (version "1.3.13")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/xelerance/xl2tpd/archive/v"
-                                  version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/xelerance/xl2tpd")
+                    (commit (string-append "v" version))))
               (sha256
                (base32
-                "0xycsxwslvwxpiw994s8prp7riybxs1kcax4ci9jh3jd65zwcsp7"))))
+                "1nzkmhi9arwd4smhr07l0sssx46w48z0cblv7xcz25wg4hw86mcd"))
+              (file-name (string-append "xl2tpd-" version "-checkout"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags (list (string-append "DESTDIR=" %output)