diff mbox series

[bug#40232] gnu: Add emacs-caps-lock.

Message ID 87tv2blxjk.fsf@lafreniere.xyz
State Accepted
Headers show
Series [bug#40232] gnu: Add emacs-caps-lock. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph March 26, 2020, 1:22 a.m. UTC
Patch file is attached.

The commentary section in the upstream ELPA package is empty, so 
the description in this recipe is highly editorialized.

--
Joseph LaFreniere

Comments

LaFreniere, Joseph March 26, 2020, 2:57 a.m. UTC | #1
This is a duplicate of bug#40232 caused by an accidental resend of 
the same patch.  It may safely be closed.  If that is something I 
can do as the reporter, please point me to the documentation for 
how to do so.

--
Joseph LaFreniere
Jack Hill March 26, 2020, 3:52 a.m. UTC | #2
On Wed, 25 Mar 2020, LaFreniere, Joseph wrote:

> This is a duplicate of bug#40232 caused by an accidental resend of the same 
> patch.  It may safely be closed.  If that is something I can do as the 
> reporter, please point me to the documentation for how to do so.

Ok, I'm closing this issue, by sending the mail to 
number-done@debbugs.gnu.org. This is something that you can do in the 
future. Additional documentation about manipulating bugs by email can be 
found at https://debbugs.gnu.org/server-control.html

Best,
Jack
Nicolas Goaziou March 30, 2020, 12:10 p.m. UTC | #3
Hello,

"LaFreniere, Joseph" <joseph@lafreniere.xyz> writes:

> Patch file is attached.
>
> The commentary section in the upstream ELPA package is empty, so the
> description in this recipe is highly editorialized.

Heh. I changed "caps-lock" into "Caps Lock".

Applied as 9782200ce5611af4c0a1a479a351d55ab4940107.

Thank you!

Regards,
diff mbox series

Patch

From fd938317abde6de68584d6162f634cac6e0948b6 Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Wed, 25 Mar 2020 20:19:33 -0500
Subject: [PATCH] gnu: Add emacs-caps-lock.

* gnu/packages/emacs-xyz.scm (emacs-caps-lock): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2bfa5f95e5..4f2552222c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1728,6 +1728,28 @@  searches.  Unlike code@{emacs-wiki.el}, it can be combined with any format.")
 Emacs buffer.")
     (license license:gpl3+)))
 
+(define-public emacs-caps-lock
+  (package
+    (name "emacs-caps-lock")
+    (version "1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://elpa.gnu.org/packages/caps-lock-"
+             version
+             ".el"))
+       (sha256
+        (base32 "1i4hwam81p4dr0bk8257fkiz4xmv6knkjxj7a00fa35kgx5blpva"))))
+    (build-system emacs-build-system)
+    (home-page
+     "http://elpa.gnu.org/packages/caps-lock.html")
+    (synopsis "Caps-lock as a minor mode")
+    (description
+     "This package provides a minor mode to emulate the behavior of a
+caps-lock key.")
+    (license license:gpl3+)))
+
 (define-public emacs-chronometrist
   (package
     (name "emacs-chronometrist")
-- 
2.26.0