diff mbox series

[bug#40677,V3,04/15] gnu: Add libnatpmp.

Message ID 87tv0y3fvr.fsf@gmail.com
State Accepted
Headers show
Series None | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Mathieu Othacehe May 2, 2020, 8:22 a.m. UTC
Hello Jan,

Thanks for this v3! I applied this one with the following edits:

--8<---------------cut here---------------start------------->8---
--8<---------------cut here---------------end--------------->8---

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 603d8b8e3a..431b0fafd4 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -439,8 +439,6 @@  files contain direct mappings of the abstractions provided by the ØMQ C API.")
                (base32
                 "1c1n8n7mp0amsd6vkz32n8zj3vnsckv308bb7na0dg0r8969rap1"))))
     (build-system gnu-build-system)
-    (native-inputs
-     `(("pkg-config" ,pkg-config)))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -448,16 +446,13 @@  files contain direct mappings of the abstractions provided by the ØMQ C API.")
          (delete 'check)) ; no tests
        #:make-flags
        (let* ((target ,(%current-target-system))
-              (gcc (if target (string-append target "-gcc") "gcc"))
-              (pkg-config (if target
-                              (string-append target "-pkg-config")
-                              "pkg-config")))
+              (gcc (if target
+                       (string-append target "-gcc")
+                       "gcc")))
          (list
           (string-append "CC=" gcc)
-          (string-append "PKG_CONFIG="
-                         (assoc-ref %build-inputs "pkg-config")
-                         "/bin/" pkg-config)
-          (string-append "PREFIX=" (assoc-ref %outputs "out"))))))
+          (string-append "INSTALLPREFIX=" (assoc-ref %outputs "out"))
+          (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib")))))
     (home-page "http://miniupnp.free.fr/libnatpmp.html")
     (synopsis "C library implementing NAT-PMP")
     (description