diff mbox series

[bug#44003,v2] gnu: emacs-julia-mode: Update to 0.4-0.8bfc709.

Message ID 87tuuuhe3e.fsf@lavabit.com
State Accepted
Headers show
Series [bug#44003,v2] gnu: emacs-julia-mode: Update to 0.4-0.8bfc709. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Tim Howes Oct. 16, 2020, 6:36 a.m. UTC
It seemed like the previous package definition used the latest commit,
but I guess that was because they had not yet put out a tagged release.

https://github.com/JuliaEditorSupport/julia-emacs/issues/46

The tagged release from March should work fine. Should it keep the
revision and commit ID as part of the version?

Comments

Brett Gilio Oct. 16, 2020, 7:32 p.m. UTC | #1
Tim Howes via Guix-patches via <guix-patches@gnu.org> writes:

>
> The tagged release from March should work fine. Should it keep the
> revision and commit ID as part of the version?
>

Using tagged releases is preferred. I would remove the commit
let-binding and go about it using version numbering.
Simon Tournier Oct. 19, 2020, 1:42 p.m. UTC | #2
Dear,

On Fri, 16 Oct 2020 at 21:33, Brett Gilio <brettg@gnu.org> wrote:

> Using tagged releases is preferred. I would remove the commit
> let-binding and go about it using version numbering.

It is currently the convention and uniformity matters. :-)
But IMHO it is bad practise.  Using commit hash enforces
content-addressed, which is obviously not the case with "tags".  Tags
are fragile for upstream in-place replacement, for example.  For
reference, [1] and BTW all the thread is worth to read. :-)

1: <https://lists.gnu.org/archive/html/guix-devel/2020-05/msg00236.html>

All the best,
simon
diff mbox series

Patch

From 6975b12dfe2478acf19a299be1942c68a40868ca Mon Sep 17 00:00:00 2001
From: Tim Howes <timhowes@lavabit.com>
Date: Thu, 15 Oct 2020 19:52:04 -0700
Subject: [PATCH v2] gnu: emacs-julia-mode: Update to 0.4-0.8bfc709.

* gnu/packages/emacs-xyz.scm (emacs-julia-mode): Update to 0.4-0.8bfc709.
---
 gnu/packages/emacs-xyz.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e3e61e3141..2392c48295 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -81,6 +81,7 @@ 
 ;;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
 ;;; Copyright © 2020 Marco Grassi <marco.au.grassi98@protonmail.com>
 ;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
+;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -7786,13 +7787,12 @@  E-Prime forbids the use of the \"to be\" form to strengthen your writing.")
       (license license:gpl3+))))
 
 (define-public emacs-julia-mode
-  ;; XXX: Upstream version remained stuck at 0.3.  See
-  ;; <https://github.com/JuliaEditorSupport/julia-emacs/issues/46>.
-  (let ((commit "115d4dc8a07445301772da8376b232fa8c7168f4")
-        (revision "1"))
+  (let ((commit "8bfc709716a257521cb386f20b8932e83db930a9")
+        (version "0.4")
+        (revision "0"))
     (package
       (name "emacs-julia-mode")
-      (version (string-append "0.3-" revision "." (string-take commit 8)))
+      (version (git-version version revision commit))
       (source
        (origin
          (method git-fetch)
@@ -7802,7 +7802,7 @@  E-Prime forbids the use of the \"to be\" form to strengthen your writing.")
          (file-name (git-file-name name version))
          (sha256
           (base32
-           "1is4dcv6blslpzbjcg8l2jpxi8xj96q4cm0nxjxsyswpm8bw8ki0"))))
+           "1w131jb9mhvyjxa0p93iwfhzidgbcs6b8i6jg79yisqb9wchik99"))))
       (build-system emacs-build-system)
       (arguments
        `(#:tests? #t
-- 
2.28.0