diff mbox series

[bug#44165] gnu: Add emacs-xonsh-mode.

Message ID 87tuulag92.fsf@odyssey.lafreniere.xyz
State New
Headers show
Series [bug#44165] gnu: Add emacs-xonsh-mode. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph Oct. 23, 2020, 1:22 a.m. UTC
Patch file is attached.

The repository has existed for over a year and is referred to by 
the upstream xonsh project (xon.sh), so the lack of a tagged 
release is not indicative of a lack of maturity.

--
Joseph LaFreniere

Comments

Nicolas Goaziou Oct. 26, 2020, 8:41 a.m. UTC | #1
Hello,

Joseph LaFreniere <joseph@lafreniere.xyz> writes:

> Patch file is attached.

Thank you. Some comments follow.
> +  ;; There is no tagged release yet.
> +  (let ((tag "0.0.0")

The version is actually "O" according to the "Version" keyword in the
Elisp file, not "0.0.0".

> +        (commit "7fa581524533a9b6b770426e4445e571a69e469d")
> +        (revision "0"))
> +    (package
> +      (name "emacs-xonsh-mode")
> +      (version (git-version tag revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/seanfarley/xonsh-mode.git")
> +               (commit commit)))
> +         (sha256
> +          (base32 "0lfi2372clkkzi4a940fwparsfhxxzb7bmysfd50n1myakgldri5"))))
> +      (build-system emacs-build-system)
> +      (home-page "https://github.com/seanfarley/xonsh-mode")
> +      (synopsis "Major mode for editing @code{xonsh} files")

  Emacs major mode for editing @file{xonshrc} files

seems slightly more accurate.

> +      (description
> +       "This package implements a major mode for xonsh scripts. The basic

Mind the two spaces after the full stop above.

> +functionality includes syntax highlight for xonsh operators.  Files with the
> +.xonshrc or .xsh extension are automatically opened with this mode.")

@file{.xonshrc} or @file{.xsh} extension

Could you send an updated patch?

Regards,
diff mbox series

Patch

From c99c1eeb00b44b54217159e8ec0814d94bb8aa09 Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Thu, 22 Oct 2020 20:15:59 -0500
Subject: [PATCH] gnu: Add emacs-xonsh-mode.

* gnu/packages/emacs-xyz.scm (emacs-xonsh-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 818db3e4e5..4ecf0eb9e1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25191,3 +25191,28 @@  the TypeScript implementation.")
       (description "This package provides an Emacs client for the Rocket.chat
 service.")
       (license license:expat))))
+
+(define-public emacs-xonsh-mode
+  ;; There is no tagged release yet.
+  (let ((tag "0.0.0")
+        (commit "7fa581524533a9b6b770426e4445e571a69e469d")
+        (revision "0"))
+    (package
+      (name "emacs-xonsh-mode")
+      (version (git-version tag revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/seanfarley/xonsh-mode.git")
+               (commit commit)))
+         (sha256
+          (base32 "0lfi2372clkkzi4a940fwparsfhxxzb7bmysfd50n1myakgldri5"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/seanfarley/xonsh-mode")
+      (synopsis "Major mode for editing @code{xonsh} files")
+      (description
+       "This package implements a major mode for xonsh scripts. The basic
+functionality includes syntax highlight for xonsh operators.  Files with the
+.xonshrc or .xsh extension are automatically opened with this mode.")
+      (license license:gpl3+))))
-- 
2.28.0