diff mbox series

[bug#44939,1/4] gnu: Add go-github-com-nwidger-jsoncolor.

Message ID 87tut8dayd.fsf@lafreniere.xyz
State Accepted
Headers show
Series [bug#44939,1/4] gnu: Add go-github-com-nwidger-jsoncolor. | expand

Commit Message

LaFreniere, Joseph Nov. 29, 2020, 4:49 a.m. UTC
Patch file attached.

--
Joseph LaFreniere

Comments

phodina Nov. 3, 2021, 8:50 a.m. UTC | #1
Hi Ludo,

seems this patch has already been merged in commit
81c7f13d74530f936d71f8404cdcc71770cf707e.

Petr
Efraim Flashner Nov. 4, 2021, 1:13 p.m. UTC | #2
On Wed, Nov 03, 2021 at 08:50:39AM +0000, phodina via Guix-patches via wrote:
> Hi Ludo,
> 
> seems this patch has already been merged in commit
> 81c7f13d74530f936d71f8404cdcc71770cf707e.
> 
> Petr

You can close bugs by changing the address from #####@debbugs.gnu.org to
#####-done@debbugs.gnu.org, like I did with this email :)
diff mbox series

Patch

From 1db67f6b7cac25a16913776431c4d3bf97ba1c9f Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sat, 28 Nov 2020 22:25:35 -0600
Subject: [PATCH 1/4] gnu: Add go-github-com-nwidger-jsoncolor.

* gnu/packages/golang.scm (go-github-com-nwidger-jsoncolor): New variable.
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 92533cfd50..72f43efd8a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5134,6 +5134,33 @@  style your output, without you having to deal with all kinds of weird ANSI
 escape sequences and color conversions.")
     (license license:expat)))
 
+(define-public go-github-com-nwidger-jsoncolor
+  (package
+    (name "go-github-com-nwidger-jsoncolor")
+    (version "0.3.0")
+    (home-page "https://github.com/nwidger/jsoncolor")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "13rd146pnj7qm70r1333gyd1f61x40nafxlpvdxlci9h7mx8c5p8"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/nwidger/jsoncolor"))
+    (native-inputs
+     `(("go-github-com-fatih-color" ,go-github-com-fatih-color)))
+    (synopsis "Colorized JSON marshalling and encoding")
+    (description
+     "@code{jsoncolor} is a drop-in replacement for @code{encoding/json}'s
+@code{Marshal} and @code{MarshalIndent} functions and @code{Encoder} type
+which produce colorized output using github.com/fatih/color.")
+    (license license:expat)))
+
 (define-public go-github-com-olekukonko-tablewriter
   (package
     (name "go-github-com-olekukonko-tablewriter")
-- 
2.29.2