diff mbox series

bug#53186: [PATCH] gnu: lua: add lua version 5.4.3

Message ID 87tue75luc.fsf@gnu.org
State New
Headers show
Series bug#53186: [PATCH] gnu: lua: add lua version 5.4.3 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès Jan. 13, 2022, 10:09 p.m. UTC
Hi Alex,

Alex Devaure <ajadevaure@gmail.com> skribis:

> After submitting a patch to update the package darktable to the last
> version, it appeared that the version 5.4 of lua is necessary. It is why
> I am submitting that patch.
> Kind regards,
> Alex
>
> ---
>  gnu/packages/lua.scm                         |  12 +++
>  gnu/packages/patches/lua-5.4-liblua-so.patch |  31 ++++++
>  gnu/packages/patches/lua-5.4-pkgconfig.patch | 106 +++++++++++++++++++

Applied with the changes below and a commit log that follows our
conventions.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 756caeea44..b9fb0f7349 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1450,6 +1450,8 @@  dist_patch_DATA =						\
   %D%/packages/patches/lua51-liblua-so.patch                    \
   %D%/packages/patches/lua51-pkgconfig.patch                    \
   %D%/packages/patches/lua-liblua-so.patch                      \
+  %D%/packages/patches/lua-5.4-pkgconfig.patch			\
+  %D%/packages/patches/lua-5.4-liblua-so.patch			\
   %D%/packages/patches/luajit-no_ldconfig.patch			\
   %D%/packages/patches/luit-posix.patch				\
   %D%/packages/patches/lvm2-static-link.patch			\
diff --git a/gnu/packages/patches/lua-5.4-liblua-so.patch b/gnu/packages/patches/lua-5.4-liblua-so.patch
index 0f35887012..93dd011143 100644
--- a/gnu/packages/patches/lua-5.4-liblua-so.patch
+++ b/gnu/packages/patches/lua-5.4-liblua-so.patch
@@ -1,3 +1,5 @@ 
+Patch the makefile to create liblua.so.
+
 --- a/src/Makefile	2021-02-09 18:47:17.000000000 +0000
 +++ b/src/Makefile	2022-01-03 11:30:36.964501941 +0000
 @@ -33,6 +33,7 @@
diff --git a/gnu/packages/patches/lua-5.4-pkgconfig.patch b/gnu/packages/patches/lua-5.4-pkgconfig.patch
index 0a80cef9db..eb42633585 100644
--- a/gnu/packages/patches/lua-5.4-pkgconfig.patch
+++ b/gnu/packages/patches/lua-5.4-pkgconfig.patch
@@ -1,3 +1,7 @@ 
+Enables generating Lua's pkg-config file.
+
+http://lua-users.org/lists/lua-l/2015-03/msg00338.html
+
 --- a/Makefile	2022-01-03 12:06:37.760402709 +0000
 +++ b/Makefile	2022-01-03 12:06:49.568402167 +0000
 @@ -14,6 +14,7 @@