diff mbox series

bug#53324: [PATCH] gnu: Add uftrace.

Message ID 87tudy7a8t.fsf_-_@gnu.org
State Accepted
Headers show
Series bug#53324: [PATCH] gnu: Add uftrace. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès Jan. 20, 2022, 2:27 p.m. UTC
Hi,

Olivier Dion <olivier.dion@polymtl.ca> skribis:

> * gnu/packages/instrumentation.scm: (uftrace): New variable.

Applied with the following tweaks.

Thanks!

Ludo’.

Comments

Olivier Dion Jan. 20, 2022, 2:33 p.m. UTC | #1
On Thu, 20 Jan 2022, Ludovic Courtès <ludo@gnu.org> wrote:
> Hi,
>
> Olivier Dion <olivier.dion@polymtl.ca> skribis:
>
>> * gnu/packages/instrumentation.scm: (uftrace): New variable.
>
> Applied with the following tweaks.
>
> Thanks!

Great, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index 29c15d1deb..a58a474a38 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -283,22 +283,16 @@  (define-public uftrace
              (invoke "./configure"
                      (string-append "--prefix="
                                     (assoc-ref outputs "out"))))))))
-    (native-search-paths
-     (list (search-path-specification
-            (variable "TERMINFO_DIRS")
-            (files '("share/terminfo")))))
     (inputs
-     (list
-      capstone
-      elfutils
-      libunwind
-      ncurses))
+     (list capstone
+           elfutils
+           libunwind
+           ncurses))
     (native-inputs
-     (list
-      luajit
-      pandoc
-      pkg-config
-      python-wrapper))
+     (list luajit
+           pandoc
+           pkg-config
+           python-wrapper))
     (home-page "https://github.com/namhyung/uftrace")
     (synopsis "Function graph tracer for C/C++/Rust")
     (description "uftrace is a tool for tracing and analyzing the execution of