diff mbox series

[bug#53455] gnu: Update emacs-dtache

Message ID 87tudvts1s.fsf@posteo.net
State Accepted
Headers show
Series [bug#53455] gnu: Update emacs-dtache | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Niklas Eklund Jan. 22, 2022, 8:49 p.m. UTC
Hi,

this patch updates the emacs-dtache package to the latest version.

/Niklas

Comments

Nicolas Goaziou Jan. 23, 2022, 9:31 a.m. UTC | #1
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

> this patch updates the emacs-dtache package to the latest version.

Applied with the following change. Thank you.

> Subject: [PATCH] gnu: emacs-dtache: Update to 0.4

The complete commit message should be:

    gnu: emacs-dtache: Update to 0.4.

    * gnu/packages/emacs-xyz.scm (emacs-dtache): Update to 0.4.

Regards,
diff mbox series

Patch

From b8e50c235727c4c70f93992086fa84f445ce041f Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Sat, 22 Jan 2022 21:46:17 +0100
Subject: [PATCH] gnu: emacs-dtache: Update to 0.4

---
 gnu/packages/emacs-xyz.scm | 85 ++++++++++++++++++--------------------
 1 file changed, 41 insertions(+), 44 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 827b6196d3..4c795c8a56 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23361,52 +23361,49 @@  (define-public emacs-cmake-font-lock
       (license license:gpl3+))))
 
 (define-public emacs-dtache
-  ;; XXX: The following commit includes a fix for a test.
-  (let ((commit "9e0acd552db62fb696bafb6b9ba9a78522309dd8")
-        (revision "0"))
-    (package
-      (name "emacs-dtache")
-      (version (git-version "0.3" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://gitlab.com/niklaseklund/dtache")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1jb48x33mhb4awnjrqi268wigp07j08xi02s9yhg8b04l6mnms0d"))))
-      (arguments
-       (list
-        #:tests? #t
-        #:test-command #~(list "ert-runner")
-        #:phases
-        #~(modify-phases %standard-phases
-            (add-before 'install 'install-dtache-env
-              (lambda _
-                (install-file "dtache-env" (string-append #$output "/bin"))))
-            (add-after 'unpack 'configure
-              (lambda* (#:key inputs #:allow-other-keys)
-                (make-file-writable "dtache.el")
-                (emacs-substitute-variables "dtache.el"
-                  ("dtache-env" (string-append #$output
-                                               "/bin/dtache-env"))
-                  ("dtache-dtach-program" (search-input-file
-                                           inputs
-                                           "/bin/dtach"))
-                  ("dtache-shell-program" (search-input-file
-                                           inputs
-                                           "/bin/bash"))))))))
-      (build-system emacs-build-system)
-      (native-inputs (list emacs-ert-runner))
-      (inputs (list dtach))
-      (home-page "https://gitlab.com/niklaseklund/dtache")
-      (synopsis "Run and interact with detached shell commands")
-      (description
-       "The dtache package allows users to run shell commands
+  (package
+    (name "emacs-dtache")
+    (version "0.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/niklaseklund/dtache")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1hndv0qzibkc4177lkam30j8cgvzxd8r60v3dnqn2bmrgxw04j6b"))))
+    (arguments
+     (list
+      #:tests? #t
+      #:test-command #~(list "ert-runner")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'install 'install-dtache-env
+            (lambda _
+              (install-file "dtache-env" (string-append #$output "/bin"))))
+          (add-after 'unpack 'configure
+            (lambda* (#:key inputs #:allow-other-keys)
+              (make-file-writable "dtache.el")
+              (emacs-substitute-variables "dtache.el"
+                ("dtache-env" (string-append #$output
+                                             "/bin/dtache-env"))
+                ("dtache-dtach-program" (search-input-file
+                                         inputs
+                                         "/bin/dtach"))
+                ("dtache-shell-program" (search-input-file
+                                         inputs
+                                         "/bin/bash"))))))))
+    (build-system emacs-build-system)
+    (native-inputs (list emacs-ert-runner))
+    (inputs (list dtach))
+    (home-page "https://gitlab.com/niklaseklund/dtache")
+    (synopsis "Run and interact with detached shell commands")
+    (description
+     "The dtache package allows users to run shell commands
 detached from Emacs.  These commands are launched in sessions, using the
 program dtach.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-dtrt-indent
   (package
-- 
2.32.0