From 65f58dae36f25c4bcb64f4b75060a2635aab7fa2 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Wed, 9 Feb 2022 23:04:04 -0600
Subject: [PATCH 5/5] image: Add wsl image.
* gnu/system/images/wsl.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
gnu/local.mk | 1 +
gnu/system/images/wsl.scm | 31 +++++++++++++++++++++++++++++++
2 files changed, 32 insertions(+)
create mode 100644 gnu/system/images/wsl.scm
@@ -708,6 +708,7 @@ GNU_SYSTEM_MODULES = \
%D%/system/images/pine64.scm \
%D%/system/images/pinebook-pro.scm \
%D%/system/images/rock64.scm \
+ %D%/system/images/wsl.scm \
\
%D%/machine.scm \
\
new file mode 100644
@@ -0,0 +1,31 @@
+;;; Copyright © 2022 Alex Griffin <a@ajgrf.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu system images wsl)
+ #:use-module (gnu image)
+ #:use-module (gnu system image)
+ #:use-module (gnu system wsl)
+ #:export (wsl-tarball-image))
+
+(define wsl-tarball-image
+ (image
+ (inherit
+ (os->image wsl-os
+ #:type wsl-tarball-image-type))
+ (name 'wsl-tarball-image)))
+
+wsl-tarball-image
--
2.34.0