diff mbox series

[bug#53912,5/5] image: Add wsl image.

Message ID 87tud7cjpg.fsf@ajgrf.com
State Accepted
Headers show
Series WIP Add WSL support. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Alex Griffin Feb. 10, 2022, 6:35 a.m. UTC
This patch adds the wsl system image. Generate it with

guix system image gnu/system/images/wsl.scm

Thanks,
–
Alex Griffin
diff mbox series

Patch

From 65f58dae36f25c4bcb64f4b75060a2635aab7fa2 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Wed, 9 Feb 2022 23:04:04 -0600
Subject: [PATCH 5/5] image: Add wsl image.

* gnu/system/images/wsl.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
 gnu/local.mk              |  1 +
 gnu/system/images/wsl.scm | 31 +++++++++++++++++++++++++++++++
 2 files changed, 32 insertions(+)
 create mode 100644 gnu/system/images/wsl.scm

diff --git a/gnu/local.mk b/gnu/local.mk
index fecde5b4dd..41f0d14c42 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -708,6 +708,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/system/images/pine64.scm			\
   %D%/system/images/pinebook-pro.scm		\
   %D%/system/images/rock64.scm			\
+  %D%/system/images/wsl.scm			\
 						\
   %D%/machine.scm				\
 						\
diff --git a/gnu/system/images/wsl.scm b/gnu/system/images/wsl.scm
new file mode 100644
index 0000000000..c4ad4a7c27
--- /dev/null
+++ b/gnu/system/images/wsl.scm
@@ -0,0 +1,31 @@ 
+;;; Copyright © 2022 Alex Griffin <a@ajgrf.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu system images wsl)
+  #:use-module (gnu image)
+  #:use-module (gnu system image)
+  #:use-module (gnu system wsl)
+  #:export (wsl-tarball-image))
+
+(define wsl-tarball-image
+  (image
+   (inherit
+    (os->image wsl-os
+               #:type wsl-tarball-image-type))
+   (name 'wsl-tarball-image)))
+
+wsl-tarball-image
-- 
2.34.0