diff mbox series

[bug#55565] gnu: Add python-blis

Message ID 87tu9ifs3m.fsf@gmail.com
State New
Headers show
Series [bug#55565] gnu: Add python-blis | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov May 21, 2022, 10:17 p.m. UTC
Hello,

this patch adds "blis" Python module[1] under the name "python-blis".

- Artyom

References:
1. "Fast matrix-multiplication as a self-contained Python library"
   https://github.com/explosion/cython-blis

Comments

Ludovic Courtès May 27, 2022, 9:23 p.m. UTC | #1
Hi Artyom,

"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

> From 3d22d0e5f7929ac1b782217ec207a5e462316c66 Mon Sep 17 00:00:00 2001
> From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
> Date: Sun, 22 May 2022 01:14:26 +0300
> Subject: [PATCH] gnu: Add python-blis
>
> * gnu/packages/python-xyz.scm (python-blis): New variable.

[...]

> +    (native-inputs (list python-pytest python-cython))
> +    (inputs (list python python-numpy python-hypothesis))
> +    (arguments
> +     ;; XXX: Tests are failing with the following error:
> +     ;; AttributeError: module 'numpy.__config__' has no attribute 'blas_ilp64_opt_info'
> +     (list #:tests? #f))

Doesn’t that failure suggest something’s really wrong?  Seems worth
investigating.

> +    (home-page "https://github.com/explosion/cython-blis")
> +    (synopsis "Fast matrix-multiplication Python library")
> +    (description
> +     "This package provides the @url{https://github.com/flame/blis,
> +Blis linear algebra} routines as a self-contained Python C-extension.")

Blis isn’t listed in ‘inputs’, and apparently that’s because it’s
bundled.

Could you “unbundle” it?  That is, add Blis as an input, make sure it
gets used during the build process, and remove the bundled copy.

Thanks in advance,
Ludo’.
Vagrant Cascadian Sept. 2, 2023, midnight UTC | #2
On 2022-05-22, Artyom V. Poptsov wrote:
> Subject: [PATCH] gnu: Add python-blis
>
> * gnu/packages/python-xyz.scm (python-blis): New variable.
...
> +(define-public python-blis
> +  (package
> +    (name "python-blis")
> +    (version "0.9.0")

python-blis 0.9.1 was added in:

069618522d3ee040e0b0f2d9f24ceb763ce434aa gnu: Add python-blis.

Marking as done.

live well,
  vagrant
diff mbox series

Patch

From 3d22d0e5f7929ac1b782217ec207a5e462316c66 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 22 May 2022 01:14:26 +0300
Subject: [PATCH] gnu: Add python-blis

* gnu/packages/python-xyz.scm (python-blis): New variable.
---
 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3c4fa16d16..95b85b9931 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31449,3 +31449,27 @@  written in C.")
     (synopsis "Cython bindings for MurmurHash2")
     (description "This package provides Cython bindings for MurmurHash2.")
     (license license:expat)))
+
+(define-public python-blis
+  (package
+    (name "python-blis")
+    (version "0.9.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "blis" version))
+              (sha256
+               (base32
+                "0adl7knj11rglg6l9nfqccl8kgs2v1c7qllv9c5kf5k796hir7k9"))))
+    (build-system python-build-system)
+    (native-inputs (list python-pytest python-cython))
+    (inputs (list python python-numpy python-hypothesis))
+    (arguments
+     ;; XXX: Tests are failing with the following error:
+     ;; AttributeError: module 'numpy.__config__' has no attribute 'blas_ilp64_opt_info'
+     (list #:tests? #f))
+    (home-page "https://github.com/explosion/cython-blis")
+    (synopsis "Fast matrix-multiplication Python library")
+    (description
+     "This package provides the @url{https://github.com/flame/blis,
+Blis linear algebra} routines as a self-contained Python C-extension.")
+    (license license:bsd-3)))
-- 
2.25.1