diff mbox series

[bug#56454] gnu: xonsh: Update to 0.13.0

Message ID 87tu7rvdl0.fsf@riseup.net
State Accepted
Headers show
Series [bug#56454] gnu: xonsh: Update to 0.13.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Edison Ibáñez July 8, 2022, 3:17 p.m. UTC

Comments

Ludovic Courtès July 10, 2022, 9:54 p.m. UTC | #1
Hi,

Edison Ibáñez <arkhan@riseup.net> skribis:

>>From 6aa6764e9b2c13e91afcd73f3725db9db446c699 Mon Sep 17 00:00:00 2001
> From: arkhan <arkhan@riseup.net>
> Date: Fri, 8 Jul 2022 09:52:54 -0500
> Subject: [PATCH] gnu: update xonsh to 1.3.0
>
> ---
>  gnu/packages/shells.scm | 17 +++++++++++------

[...]

> +    (version "0.13.0")
>      (source
>        (origin
>          (method url-fetch)
> @@ -554,15 +556,12 @@ (define-public xonsh
>            (base32 "0xlac84nsgs0052n2pw8np1smlgghrbd7p6yrcp7d5qh8zdr9lx3"))

Look like you forgot to update the hash, which leads to:

--8<---------------cut here---------------start------------->8---
downloading from https://files.pythonhosted.org/packages/source/x/xonsh/xonsh-0.13.0.tar.gz ...
 xonsh-0.13.0.tar.gz  751KiB                           17.1MiB/s 00:00 [##################] 100.0%
sha256 hash mismatch for /gnu/store/jy4fj2bbgrmhi164z3qk6423mhdzma00-xonsh-0.13.0.tar.gz:
  expected hash: 0xlac84nsgs0052n2pw8np1smlgghrbd7p6yrcp7d5qh8zdr9lx3
  actual hash:   12ayz1kw2ag3r407j0lng2kfp75im8xqap1nvpmpa0lmsx8wk7ll
hash mismatch for store item '/gnu/store/jy4fj2bbgrmhi164z3qk6423mhdzma00-xonsh-0.13.0.tar.gz'
--8<---------------cut here---------------end--------------->8---

>      (inputs
> -     (list python-ply))
> +     (list python-distro
> +           python-ply
> +           python-pygments
> +           python-pyperclip
> +           python-setproctitle
> +           python-setuptools
> +           python-wheel))

‘guix lint’ reports this:

--8<---------------cut here---------------start------------->8---
$ ./pre-inst-env  guix lint xonsh
gnu/packages/shells.scm:589:5: xonsh@0.13.0: 'python-setuptools' should probably not be an input at all
--8<---------------cut here---------------end--------------->8---

Is setuptools used at run time?  If not, which is likely, it probably
shouldn’t be there.

Could you send an updated patch?

Bonus points if you can provide a ChangeLog-style commit log.  :-)

  https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html

Thanks,
Ludo’.
Edison Ibáñez July 11, 2022, 3:10 p.m. UTC | #2
El 2022-07-10 16:54, Ludovic Courtès escribió:
> Hi,
> 
> Edison Ibáñez <arkhan@riseup.net> skribis:
> 
>>>From 6aa6764e9b2c13e91afcd73f3725db9db446c699 Mon Sep 17 00:00:00 2001
>> From: arkhan <arkhan@riseup.net>
>> Date: Fri, 8 Jul 2022 09:52:54 -0500
>> Subject: [PATCH] gnu: update xonsh to 1.3.0
>>
>> ---
>>  gnu/packages/shells.scm | 17 +++++++++++------
> 
> [...]
> 
>> +    (version "0.13.0")
>>      (source
>>        (origin
>>          (method url-fetch)
>> @@ -554,15 +556,12 @@ (define-public xonsh
>>            (base32 "0xlac84nsgs0052n2pw8np1smlgghrbd7p6yrcp7d5qh8zdr9lx3"))
> 

Sorry, I missed it, I already sent the updated patch

> Look like you forgot to update the hash, which leads to:
> 
> --8<---------------cut here---------------start------------->8---
> downloading from
> https://files.pythonhosted.org/packages/source/x/xonsh/xonsh-0.13.0.tar.gz
> ...
>  xonsh-0.13.0.tar.gz  751KiB                           17.1MiB/s 00:00
> [##################] 100.0%
> sha256 hash mismatch for
> /gnu/store/jy4fj2bbgrmhi164z3qk6423mhdzma00-xonsh-0.13.0.tar.gz:
>   expected hash: 0xlac84nsgs0052n2pw8np1smlgghrbd7p6yrcp7d5qh8zdr9lx3
>   actual hash:   12ayz1kw2ag3r407j0lng2kfp75im8xqap1nvpmpa0lmsx8wk7ll
> hash mismatch for store item
> '/gnu/store/jy4fj2bbgrmhi164z3qk6423mhdzma00-xonsh-0.13.0.tar.gz'
> --8<---------------cut here---------------end--------------->8---
> 
>>      (inputs
>> -     (list python-ply))
>> +     (list python-distro
>> +           python-ply
>> +           python-pygments
>> +           python-pyperclip
>> +           python-setproctitle
>> +           python-setuptools
>> +           python-wheel))
> 
> ‘guix lint’ reports this:
> 
> --8<---------------cut here---------------start------------->8---
> $ ./pre-inst-env  guix lint xonsh
> gnu/packages/shells.scm:589:5: xonsh@0.13.0: 'python-setuptools'
> should probably not be an input at all
> --8<---------------cut here---------------end--------------->8---
> 
> Is setuptools used at run time?  If not, which is likely, it probably
> shouldn’t be there.
> 

python-setuptools and python-wheel are not required for run time but for
package build, so in patch update I moved them to native-inputs

> Could you send an updated patch?
> 
> Bonus points if you can provide a ChangeLog-style commit log.  :-)
> 
>   https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html
> 
> Thanks,
> Ludo’.

Thanks for taking the time to review this.
Edison.
diff mbox series

Patch

From 6aa6764e9b2c13e91afcd73f3725db9db446c699 Mon Sep 17 00:00:00 2001
From: arkhan <arkhan@riseup.net>
Date: Fri, 8 Jul 2022 09:52:54 -0500
Subject: [PATCH] gnu: update xonsh to 1.3.0

---
 gnu/packages/shells.scm | 17 +++++++++++------
 1 file changed, 11 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 9fe0ed8e27..7675fe84e9 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -57,6 +57,7 @@  (define-module (gnu packages shells)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages rust)
@@ -64,6 +65,7 @@  (define-module (gnu packages shells)
   #:use-module (gnu packages scheme)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages version-control)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages texinfo)
   #:use-module (guix build-system cargo)
@@ -545,7 +547,7 @@  (define-public zsh
 (define-public xonsh
   (package
     (name "xonsh")
-    (version "0.12.4")
+    (version "0.13.0")
     (source
       (origin
         (method url-fetch)
@@ -554,15 +556,12 @@  (define-public xonsh
           (base32 "0xlac84nsgs0052n2pw8np1smlgghrbd7p6yrcp7d5qh8zdr9lx3"))
         (modules '((guix build utils)))
         (snippet
-         `(begin
-            ;; Delete bundled PLY.
-            (delete-file-recursively "xonsh/ply")
+         #~(begin
             (substitute* "setup.py"
               (("\"xonsh\\.ply\\.ply\",") ""))
             ;; Use our properly packaged PLY instead.
             (substitute* (list "setup.py"
                                "tests/test_lexer.py"
-                               "xonsh/__amalgam__.py"
                                "xonsh/lexer.py"
                                "xonsh/parsers/base.py"
                                "xonsh/parsers/completion_context.py"
@@ -587,7 +586,13 @@  (define-public xonsh
                      (invoke "python" "setup.py" "install" "--root=/"
                              (string-append "--prefix=" out))))))))
     (inputs
-     (list python-ply))
+     (list python-distro
+           python-ply
+           python-pygments
+           python-pyperclip
+           python-setproctitle
+           python-setuptools
+           python-wheel))
     (home-page "https://xon.sh/")
     (synopsis "Python-ish shell")
     (description
-- 
2.36.1