diff mbox series

bug#59685: [PATCH] gnu: Add guile-jtd.

Message ID 87tu25bmei.fsf@gnu.org
State New
Headers show
Series bug#59685: [PATCH] gnu: Add guile-jtd. | expand

Commit Message

Ludovic Courtès Dec. 8, 2022, 9:44 p.m. UTC
Hi,

jgart <jgart@dismail.de> skribis:

> * gnu/packages/guile-xyz.scm (guile-jtd): New variable.

Applied with the changes below, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 9ce895e977..9fc6344491 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3569,24 +3569,24 @@  (define-public guile-jpeg
 (define-public guile-jtd
   (package
     (name "guile-jtd")
-    (version "220323")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/mwette/guile-jtd")
-             (commit (string-append "v" version "a"))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "1l8fyqhvksarvpbr903i3ss3432jzvyvhgcqa15j922ngqh4ds6f"))))
+    (version "220323a")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mwette/guile-jtd")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1l8fyqhvksarvpbr903i3ss3432jzvyvhgcqa15j922ngqh4ds6f"))))
     (build-system guile-build-system)
-    (native-inputs
-     (list guile-3.0))
+    (native-inputs (list guile-3.0))
     (home-page "https://github.com/mwette/guile-jtd")
-    (synopsis "Python's pdb.set_trace() but for Guile")
+    (synopsis "Python's @code{pdb.set_trace()} but for Guile")
     (description
-"The (jtd) module for Guile provides a procedure @code{jump-to-debugger}
-for escaping to the Guile REPL for the purpose of debugging code.")
+     "The @code{(jtd)} module for Guile provides a procedure
+@code{jump-to-debugger} for escaping to the Guile REPL for the purpose of
+debugging code.")
     (license license:lgpl2.1+)))
 
 (define-public guile-png