diff mbox series

[bug#60509,1/3] gnu: Add go-github-com-google-gopacket.

Message ID 87tu18m6bf.wl-hako@ultrarare.space
State New
Headers show
Series gnu: Add phantomsocks. | expand

Commit Message

Hilton Chain Jan. 3, 2023, 7:21 a.m. UTC
* gnu/packages/golang.scm (go-github-com-google-gopacket): New variable.
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 70ddef52f1..ed482502a8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7043,6 +7043,28 @@  (define-public go-github-com-google-uuid
 4122 and DCE 1.1: Authentication and Security Services.")
     (license license:bsd-3)))
 
+(define-public go-github-com-google-gopacket
+  (package
+    (name "go-github-com-google-gopacket")
+    (version "1.1.19")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/google/gopacket")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "048qwm2n0wrpql4qqgd7jyynn3gk069yvqbxnshlayzmbhf87ls4"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/google/gopacket"))
+    (home-page "https://github.com/google/gopacket")
+    (synopsis "Packet processing capabilities library")
+    (description
+     "This package provides packet processing capabilities for Go.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-google-goterm
   (let ((commit "fc88cf888a3fa99ecc23d1efc1a44284268457d3")
         (revision "1"))