diff mbox series

[bug#61903] Fwd: Re: [PATCH] Update fish to 3.6.0

Message ID 87ttz3ijz3.fsf@disroot.org
State New
Headers show
Series [bug#61903] Fwd: Re: [PATCH] Update fish to 3.6.0 | expand

Commit Message

Adriel Dumas--Jondeau March 2, 2023, 9:21 a.m. UTC
And of course I also created a new patch request instead of commenting
on the other one.

I think we can close 61904, and I'm really sorry about that :(

Adriel Dumas--Jondeau <leirda@disroot.org> writes:

> Aye,
>
> I sent the wrong patch (I formatted the latest retrieved commit on
> origin instead of my local branch).
>
> Here's the right one, I'm sorry for the noise.
diff mbox series

Patch

diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 0c8cbf3f4c..f550a2c943 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -118,7 +118,7 @@  (define-public dash
 (define-public fish
   (package
     (name "fish")
-    (version "3.5.1")
+    (version "3.6.0")
     (source
      (origin
        (method url-fetch)
@@ -126,15 +126,11 @@  (define-public fish
                            "releases/download/" version "/"
                            "fish-" version ".tar.xz"))
        (sha256
-        (base32 "0a39vf0wqq6asw5xcrwgdsc67h5bxkgxzy77f8bx6pd4qlympm56"))
-       (modules '((guix build utils)))
-       (snippet
-        '(begin
-           ;; Remove bundled software.
-           (delete-file-recursively "pcre2")))))
+        (base32 "10b1xa1hpmi62rzh3qgxlw7xrhyigs8kssagccawmrryfxbls14p"))
+       (modules '((guix build utils)))))
     (build-system cmake-build-system)
     (inputs
-     (list fish-foreign-env ncurses pcre2 ; don't use the bundled PCRE2
+     (list fish-foreign-env ncurses pcre2
            python))  ; for fish_config and manpage completions
     (native-inputs
      (list doxygen groff ; for 'fish --help'