diff mbox series

[bug#63435] Add vcmi 1.2.1 to games.scm

Message ID 87ttwhm2vg.fsf@wireframe
State New
Headers show
Series [bug#63435] Add vcmi 1.2.1 to games.scm | expand

Commit Message

Vagrant Cascadian May 13, 2023, 1:33 a.m. UTC
On 2023-05-12, Liliana Marie Prikler wrote:
> Am Donnerstag, dem 11.05.2023 um 23:17 -0700 schrieb Vagrant Cascadian:
>> On 2023-05-12, Liliana Marie Prikler wrote:
>> > Am Donnerstag, dem 11.05.2023 um 16:07 -0700 schrieb Vagrant
>> > Cascadian:
>> > 
>> > > +(define-public vcmi
>> > > +  (package
>> > > +    (name "vcmi")
>> > > +    (version "1.2.1")
>> > > +    (source (origin
>> > > +              (method git-fetch)
>> > > +              (uri (git-reference
>> > > +                    (url "https://github.com/vcmi/vcmi")
>> > > +                    (commit version)
>> > > +                    (recursive? #t)))
>> > Can we do without the recursive checkout?
>> 
>> There is one component still used with the recursive
>> checkout. ... AI/Fuzzy* I think? I do not know if it could be built
>> independently, but I have not seriously looked into it.
> fuzzylite can be taken from the system which is the preferred approach.

Attached is fuzzylite as it's own package.


>> > > +    (native-inputs (list boost
>> > Guix style is, like, a suggestion that can be wrong.  You are
>> > allowed
>> > to fight it when the result of doing so is demonstrably better.
...
>> I am also not strongly opinionated (it goes both ways, I guess!)...
>> so for clarity, are you saying you would prefer:
>> 
>>   (native-inputs
>>     (list
>>       boost
>>       ...
>> or:
>> 
>>   (native-inputs
>>     (list boost
>>           ...
>> 
>> or something else?
> The latter.  If it ever comes to needing (list on its own line you
> better have a good explanation for that or fix your comments so that
> they don't go overboard.

...and will send an updated vcmi with this depending on fuzzylite
shortly.

live well,
  vagrant

Comments

Liliana Marie Prikler May 13, 2023, 6:12 a.m. UTC | #1
Hi,

Am Freitag, dem 12.05.2023 um 18:33 -0700 schrieb Vagrant Cascadian:

> +  %D%/packages/patches/fuzzylite-relative-path-in-tests.patch	\
> +  %D%/packages/patches/fuzzylite-use-catch2.patch		\
> +  %D%/packages/patches/fuzzylite-when-testing-large-float-numbers-
> for-equ.patch	
Prefer names that don't blow up the file name, e.g. "fuzzylite-fix-
test", "fuzzylite-soften-float-equality", or "fuzzylite-workaround-
issue-N" – although I'm not sure whether we have a precedent for the
latter.

> +              (patches (search-patches "fuzzylite-use-catch2.patch"
> +                        "fuzzylite-when-testing-large-float-numbers-
> for-equ.patch"
> +                        "fuzzylite-relative-path-in-tests.patch"))))
This doesn't appear properly indented.

> +    (synopsis "fuzzy logic control binary")
Capitalize the first word.  IIRC we also allow title case for proper
names and such, but I don't think that'd be necessary here.

> +     "fuzzylite is a fuzzy logic control library which allows one
> +to easily create fuzzy logic controllers in a few steps utilizing
> +object-oriented programming.")
Proper sentences start with an uppercase letter.  The convention is to
use @-constructs when the package name prohibits that.  You can also
cheat via "This package provides ..."

> +    (license license:gpl3)))
No +?

> fuzzylite is a registered trademark of FuzzyLite Limited.
Perhaps also look into their trademark policy then, if they have any.

> +-#include "test/catch.hpp"
> ++#include "catch2/catch.hpp"
Use <catch2/catch.hpp> to signal that this is a system header.

Cheers
diff mbox series

Patch

From 6514e69a082ca9c268677d7c04d858d0fdf07a11 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Fri, 12 May 2023 16:18:18 -0700
Subject: [PATCH 1/2] gnu: Add fuzzylite 6.0.

* gnu/packages/games.scm (fuzzylite): New variable.
* gnu/packages/patches/fuzzylite-relative-path-in-tests.patch: New patch.
* gnu/packages/patches/fuzzylite-use-catch2.patch: New patch.
* gnu/packages/patches/fuzzylite-when-testing-large-float-numbers-for-equ.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Add patches.
---
 gnu/local.mk                                  |   3 +
 gnu/packages/games.scm                        |  31 +++
 .../fuzzylite-relative-path-in-tests.patch    |  15 ++
 .../patches/fuzzylite-use-catch2.patch        | 184 ++++++++++++++++++
 ...-testing-large-float-numbers-for-equ.patch |  30 +++
 5 files changed, 263 insertions(+)
 create mode 100644 gnu/packages/patches/fuzzylite-relative-path-in-tests.patch
 create mode 100644 gnu/packages/patches/fuzzylite-use-catch2.patch
 create mode 100644 gnu/packages/patches/fuzzylite-when-testing-large-float-numbers-for-equ.patch

diff --git a/gnu/local.mk b/gnu/local.mk
index d31b40f3bf..89791bea69 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1149,6 +1149,9 @@  dist_patch_DATA =						\
   %D%/packages/patches/freeimage-unbundle.patch		\
   %D%/packages/patches/fuse-glibc-2.34.patch			\
   %D%/packages/patches/fuse-overlapping-headers.patch		\
+  %D%/packages/patches/fuzzylite-relative-path-in-tests.patch	\
+  %D%/packages/patches/fuzzylite-use-catch2.patch		\
+  %D%/packages/patches/fuzzylite-when-testing-large-float-numbers-for-equ.patch	\
   %D%/packages/patches/fxdiv-system-libraries.patch		\
   %D%/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch	\
   %D%/packages/patches/ganeti-disable-version-symlinks.patch	\
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index bae79ee48b..4395476af3 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3557,6 +3557,37 @@  (define-public freedink
               ("bash" ,bash)))
     (native-inputs '())))
 
+(define-public fuzzylite
+  (package
+    (name "fuzzylite")
+    (version "6.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/fuzzylite/fuzzylite")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0yay0qc81x0irlvxqpy7jywjxpkmpjabdhq2hdh28r9z85wp2nwb"))
+              (patches (search-patches "fuzzylite-use-catch2.patch"
+                        "fuzzylite-when-testing-large-float-numbers-for-equ.patch"
+                        "fuzzylite-relative-path-in-tests.patch"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-before 'configure 'switch-to-fuzzylite-dir
+                    (lambda _
+                      (chdir "fuzzylite"))))))
+    (native-inputs (list catch2))
+    (home-page "https://www.fuzzylite.com/")
+    (synopsis "fuzzy logic control binary")
+    (description
+     "fuzzylite is a fuzzy logic control library which allows one
+to easily create fuzzy logic controllers in a few steps utilizing
+object-oriented programming.")
+    (license license:gpl3)))
+
 (define-public xboard
   (package
     (name "xboard")
diff --git a/gnu/packages/patches/fuzzylite-relative-path-in-tests.patch b/gnu/packages/patches/fuzzylite-relative-path-in-tests.patch
new file mode 100644
index 0000000000..1a03238246
--- /dev/null
+++ b/gnu/packages/patches/fuzzylite-relative-path-in-tests.patch
@@ -0,0 +1,15 @@ 
+Workaround https://github.com/fuzzylite/fuzzylite/issues/85
+
+diff --git a/fuzzylite/test/BenchmarkTest.cpp b/fuzzylite/test/BenchmarkTest.cpp
+index f868ec29..464d394d 100644
+--- a/fuzzylite/test/BenchmarkTest.cpp
++++ b/fuzzylite/test/BenchmarkTest.cpp
+@@ -30,7 +30,7 @@ namespace fl {
+     }
+ 
+     TEST_CASE("Benchmarks from FLD files", "[benchmark][fld]") {
+-        std::string path = "../../examples/";
++        std::string path = "../examples/";
+         typedef std::pair<std::string, int > Example;
+         std::vector<Example> examples;
+         examples.push_back(Example("mamdani/AllTerms", int(1e4)));
diff --git a/gnu/packages/patches/fuzzylite-use-catch2.patch b/gnu/packages/patches/fuzzylite-use-catch2.patch
new file mode 100644
index 0000000000..e4aa13a98b
--- /dev/null
+++ b/gnu/packages/patches/fuzzylite-use-catch2.patch
@@ -0,0 +1,184 @@ 
+Origin: https://salsa.debian.org/debian/fuzzylite/-/blob/debian/6.0+dfsg-6/debian/patches/fix-tests2.patch
+From: Ferdinand Thiessen <rpm@fthiessen.de>
+Date: Mon, 31 Jan 2022 16:06:19 GMT
+Subject: Replace Catch with Catch2 and require C++11 for tests
+Origin: vendor, https://github.com/fuzzylite/fuzzylite/issues/94
+Bug-Debian: http://bugs.debian.org/1017155
+
+--- a/fuzzylite/CMakeLists.txt
++++ b/fuzzylite/CMakeLists.txt
+@@ -194,7 +194,9 @@ if(FL_BUILD_BINARY)
+ endif(FL_BUILD_BINARY)
+ 
+ if(FL_BUILD_TESTS)
++    find_package(Catch2)
+     add_executable(fl-test ${fl-headers} ${fl-tests})
++    target_link_libraries(fl-test Catch2::Catch2)
+     set_target_properties(fl-test PROPERTIES OUTPUT_NAME fuzzylite-tests)
+     set_target_properties(fl-test PROPERTIES OUTPUT_NAME fuzzylite-tests IMPORT_PREFIX tmp-) #To prevent LNK1149 in Windows
+     set_target_properties(fl-test PROPERTIES DEBUG_POSTFIX -debug)
+--- a/fuzzylite/test/activation/ThresholdTest.cpp
++++ b/fuzzylite/test/activation/ThresholdTest.cpp
+@@ -14,7 +14,7 @@
+  fuzzylite is a registered trademark of FuzzyLite Limited.
+  */
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ #include "fl/Headers.h"
+ 
+ namespace fl {
+--- a/fuzzylite/test/BenchmarkTest.cpp
++++ b/fuzzylite/test/BenchmarkTest.cpp
+@@ -16,7 +16,7 @@
+ 
+ #include "fl/Benchmark.h"
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ #include "fl/Headers.h"
+ 
+ #include <vector>
+--- a/fuzzylite/test/hedge/HedgeFunctionTest.cpp
++++ b/fuzzylite/test/hedge/HedgeFunctionTest.cpp
+@@ -14,7 +14,7 @@
+  fuzzylite is a registered trademark of FuzzyLite Limited.
+  */
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ #include "fl/Headers.h"
+ 
+ namespace fl {
+--- a/fuzzylite/test/imex/FldExporterTest.cpp
++++ b/fuzzylite/test/imex/FldExporterTest.cpp
+@@ -14,7 +14,7 @@
+  fuzzylite is a registered trademark of FuzzyLite Limited.
+  */
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ #include "fl/Headers.h"
+ 
+ namespace fl {
+--- a/fuzzylite/test/imex/FllImporterTest.cpp
++++ b/fuzzylite/test/imex/FllImporterTest.cpp
+@@ -14,7 +14,7 @@
+  fuzzylite is a registered trademark of FuzzyLite Limited.
+  */
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ #include "fl/Headers.h"
+ 
+ namespace fl {
+--- a/fuzzylite/test/imex/RScriptExporterTest.cpp
++++ b/fuzzylite/test/imex/RScriptExporterTest.cpp
+@@ -14,7 +14,7 @@
+  fuzzylite is a registered trademark of FuzzyLite Limited.
+  */
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ #include "fl/Headers.h"
+ #include <fstream>
+ 
+--- a/fuzzylite/test/MainTest.cpp
++++ b/fuzzylite/test/MainTest.cpp
+@@ -16,7 +16,7 @@
+  
+ #define CATCH_CONFIG_RUNNER
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ 
+ #include "fl/Headers.h"
+ 
+--- a/fuzzylite/test/norm/NormFunctionTest.cpp
++++ b/fuzzylite/test/norm/NormFunctionTest.cpp
+@@ -14,7 +14,7 @@
+  fuzzylite is a registered trademark of FuzzyLite Limited.
+  */
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ #include "fl/Headers.h"
+ 
+ namespace fl {
+--- a/fuzzylite/test/QuickTest.cpp
++++ b/fuzzylite/test/QuickTest.cpp
+@@ -14,7 +14,7 @@
+  fuzzylite is a registered trademark of FuzzyLite Limited.
+  */
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ #include "fl/Headers.h"
+ 
+ namespace fl {
+--- a/fuzzylite/test/term/AggregatedTest.cpp
++++ b/fuzzylite/test/term/AggregatedTest.cpp
+@@ -14,7 +14,7 @@
+  fuzzylite is a registered trademark of FuzzyLite Limited.
+  */
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ #include "fl/Headers.h"
+ 
+ namespace fl {
+--- a/fuzzylite/test/term/DiscreteTest.cpp
++++ b/fuzzylite/test/term/DiscreteTest.cpp
+@@ -14,7 +14,7 @@
+  fuzzylite is a registered trademark of FuzzyLite Limited.
+  */
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ #include "fl/Headers.h"
+ 
+ namespace fl {
+--- a/fuzzylite/test/term/FunctionTest.cpp
++++ b/fuzzylite/test/term/FunctionTest.cpp
+@@ -14,7 +14,7 @@
+  fuzzylite is a registered trademark of FuzzyLite Limited.
+  */
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ #include "fl/Headers.h"
+ 
+ namespace fl {
+--- a/fuzzylite/test/term/TrapezoidTest.cpp
++++ b/fuzzylite/test/term/TrapezoidTest.cpp
+@@ -14,7 +14,7 @@
+  fuzzylite is a registered trademark of FuzzyLite Limited.
+  */
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ #include "fl/Headers.h"
+ 
+ namespace fl {
+--- a/fuzzylite/test/term/TriangleTest.cpp
++++ b/fuzzylite/test/term/TriangleTest.cpp
+@@ -14,7 +14,7 @@
+  fuzzylite is a registered trademark of FuzzyLite Limited.
+  */
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ #include "fl/Headers.h"
+ 
+ namespace fl {
+--- a/fuzzylite/test/variable/VariableTest.cpp
++++ b/fuzzylite/test/variable/VariableTest.cpp
+@@ -14,7 +14,7 @@
+  fuzzylite is a registered trademark of FuzzyLite Limited.
+  */
+ 
+-#include "test/catch.hpp"
++#include "catch2/catch.hpp"
+ #include "fl/Headers.h"
+ 
+ #include <algorithm>    // std::random_shuffle
diff --git a/gnu/packages/patches/fuzzylite-when-testing-large-float-numbers-for-equ.patch b/gnu/packages/patches/fuzzylite-when-testing-large-float-numbers-for-equ.patch
new file mode 100644
index 0000000000..47403605dd
--- /dev/null
+++ b/gnu/packages/patches/fuzzylite-when-testing-large-float-numbers-for-equ.patch
@@ -0,0 +1,30 @@ 
+Origin: https://salsa.debian.org/debian/fuzzylite/-/blob/debian/6.0+dfsg-6/debian/patches/when-testing-large-float-numbers-for-equ.patch
+From: Johannes 'josch' Schauer <josch@debian.org>
+Date: Sun, 3 Feb 2019 10:33:22 +0100
+X-Dgit-Generated: 6.0+dfsg-2 80960ae38da9db032dfbfec6405398653e8205ff
+Subject: when testing large float numbers for equality, use a larger epsilon
+
+
+---
+
+--- fuzzylite-6.0+dfsg.orig/fuzzylite/test/BenchmarkTest.cpp
++++ fuzzylite-6.0+dfsg/fuzzylite/test/BenchmarkTest.cpp
+@@ -96,7 +96,17 @@ namespace fl {
+         CHECK(Op::isEq(1.0, Benchmark::convert(1000.0, Benchmark::MilliSeconds, Benchmark::Seconds)));
+         FL_LOG(Benchmark::convert(1000.0, Benchmark::MilliSeconds, Benchmark::Seconds));
+ 
+-        CHECK(Op::isEq(35e9, Benchmark::convert(35, Benchmark::Seconds, Benchmark::NanoSeconds)));
++        scalar eps =
++#ifndef __i386__
++            fuzzylite::macheps();
++#else
++            // on i386, due to the 80bit x87 register, double floating point
++            // numbers are handled differently and thus the difference between
++            // 35e9 and the result of Benchmark::convert() will be 2.179e-6,
++            // which is greater than the default epsilon of 1e-6.
++            1e-5;
++#endif
++        CHECK(Op::isEq(35e9, Benchmark::convert(35, Benchmark::Seconds, Benchmark::NanoSeconds), eps));
+         CHECK(Op::isEq(35, Benchmark::convert(35e9, Benchmark::NanoSeconds, Benchmark::Seconds)));
+     }
+ 
-- 
2.39.2