From 60c09ab615cb929be2215adc6b85ce3c8cd3fcfa Mon Sep 17 00:00:00 2001
From: Distopico <distopico@riseup.net>
Date: Sun, 23 Jul 2023 13:37:39 -0500
Subject: [PATCH] gnu: Add andorid-sdkmanager.
* gnu/packages/android.scm (sdkmanager): New variables.
---
gnu/packages/android.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
@@ -12,6 +12,7 @@
;;; Copyright © 2020 Sergey Trofimov <sarg@sarg.org.ru>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -52,6 +53,7 @@ (define-module (gnu packages android)
#:use-module (gnu packages linux)
#:use-module (gnu packages pcre)
#:use-module (gnu packages python)
+ #:use-module (guix build-system pyproject)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -721,6 +723,29 @@ (define-public fastboot
"This package provides @command{fastboot}, a tool to upload file system images to Android devices.")
(license license:asl2.0)))
+(define-public sdkmanager
+ (package
+ (name "sdkmanager")
+ (version "0.6.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sdkmanager" version ".tar.gz"))
+ (sha256
+ (base32
+ "11as7n2mj3nbqsqb3ivyv9985n73i022s748qvjg36cs8ig50afx"))))
+ (build-system pyproject-build-system)
+ (inputs (list python-requests python-argcomplete python-urllib3))
+ (propagated-inputs (list gnupg))
+ (home-page "https://gitlab.com/fdroid/sdkmanager")
+ (synopsis
+ "Replacement for Android sdkmanager written in Python")
+ (description
+ "This package provides a drop-in replacement for sdkmanager from
+the Android SDK. It is written in Python and part of the F-Droid
+project. It implements the exact API of the Android sdkmanager command
+line. The project also attempts to maintain the same terminal output.")
+ (license license:agpl3+)))
+
(define-public android-udev-rules
(package
(name "android-udev-rules")
base-commit: 13cb9b302868b5a966a6ae177412c474084f4bf1
--
2.41.0