diff mbox series

[bug#64813] gnu: Add python-manimpango.

Message ID 87ttoigd69.fsf@troyfigiel.com
State New
Headers show
Series [bug#64813] gnu: Add python-manimpango. | expand

Commit Message

Troy Figiel Dec. 16, 2023, 7:24 p.m. UTC
* gnu/packages/python-xyz.scm (python-manimpango): New variable.

Change-Id: I5ee6faa9cfd51a173f73d03c5c18e3c7d399582a
---
 gnu/packages/python-xyz.scm | 35 ++++++++++++++++++++++++++++++++++-
 1 file changed, 34 insertions(+), 1 deletion(-)


base-commit: d5298c5e334e56a9aabddcb62d312e63135864f6
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 86f8d81689..6bc02393e0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -119,7 +119,7 @@ 
 ;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
 ;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
-;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022, 2023 Wamm K. D. <jaft.r@outlook.com>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
@@ -9615,6 +9615,39 @@  (define-public python-pywinrm
 any machine that can run Python.")
     (license license:expat)))
 
+(define-public python-manimpango
+  (package
+    (name "python-manimpango")
+    (version "0.5.0")
+    (source
+     (origin
+       ;; Test fixtures are not included in the PyPI tarball. We need the Github
+       ;; release to successfully run the tests.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ManimCommunity/ManimPango")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "00mrvswk8yly0m13jq0f432pr19sy3j6w37lrv78ah1j6jz9n50h"))))
+    (build-system pyproject-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (add-before 'check 'build-extensions
+                    (lambda _
+                      (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+    (native-inputs (list pkg-config python-cython python-pytest
+                         python-pytest-cov))
+    (inputs (list pango))
+    (home-page "https://pypi.org/project/ManimPango/")
+    (synopsis "Bindings for Pango for using with Manim")
+    (description
+     "Python bindings for ManimPango which is a C binding for Pango,
+using Cython.
+
+ManimPango is internally used in Manim to render (non-LaTeX) text.")
+    (license license:expat)))
+
 (define-public python-xcffib
   (package
     (name "python-xcffib")