diff mbox series

[bug#68069] gnu: Add python-pytest-cookies.

Message ID 87tto3comb.fsf@troyfigiel.com
State New
Headers show
Series [bug#68069] gnu: Add python-pytest-cookies. | expand

Commit Message

Troy Figiel Dec. 27, 2023, 9:29 p.m. UTC
* gnu/packages/python-check.scm (python-pytest-cookies): New variable.

Change-Id: I0b085d345bf1bce5fc9c03315da06954cf2125cb
---
 gnu/packages/python-check.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: 5bd80ccd69047b1777749e24d4adf2c951b5d14b

Comments

Mathieu Othacehe Dec. 28, 2023, 9:22 a.m. UTC | #1
> * gnu/packages/python-check.scm (python-pytest-cookies): New variable.

Applied, thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index ea74472270..f02ca10298 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -583,6 +583,38 @@  (define-public python-pytest-arraydiff
 are too large to conveniently hard-code them in the tests.")
     (license license:bsd-3)))
 
+(define-public python-pytest-cookies
+  (package
+    (name "python-pytest-cookies")
+    (version "0.7.0")
+    (source
+     (origin
+       ;; No tests in the PyPI tarball.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/hackebrot/pytest-cookies")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1x7ny6mx1siy9law1cv1i63nvv9ds2g1dlagm40l8qymxry43mjn"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "pytest" "-vv")))))))
+    (native-inputs (list python-pytest))
+    (propagated-inputs (list python-cookiecutter))
+    (home-page "https://github.com/hackebrot/pytest-cookies")
+    (synopsis "Pytest plugin for Cookiecutter templates")
+    (description
+     "This Pytest plugin adds a @code{cookies} fixture, which is a
+wrapper for the Cookiecutter API.  This fixture helps you verify that
+your template is working as expected and takes care of cleaning up after
+running the tests.")
+    (license license:expat)))
+
 (define-public python-pytest-doctestplus
   (package
     (name "python-pytest-doctestplus")