diff mbox series

[bug#68293] gnu: darktable: update to 4.6.0

Message ID 87ttnqs8my.fsf@gmail.com
State New
Headers show
Series [bug#68293] gnu: darktable: update to 4.6.0 | expand

Commit Message

Alex Devaure Jan. 6, 2024, 4:52 p.m. UTC
Hi,
Here is the patch for the update of darktable,
gcc is replacing clang like in issue 67719 that has
not been integrated yet.

Change-Id: Ieb1a4dc0631330501ed38c9c2d30543d99c30296
---
 gnu/packages/photo.scm | 21 +++++----------------
 1 file changed, 5 insertions(+), 16 deletions(-)


base-commit: 157ad70182ade608203e9c0a42fb45b022039698
diff mbox series

Patch

diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 78ae61c799..2e93d895f3 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -54,6 +54,7 @@  (define-module (gnu packages photo)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages file)
   #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages geo)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages ghostscript)
@@ -528,7 +529,7 @@  (define-public lensfun
 (define-public darktable
   (package
     (name "darktable")
-    (version "4.4.2")
+    (version "4.6.0")
     (source
      (origin
        (method url-fetch)
@@ -536,7 +537,7 @@  (define-public darktable
              "https://github.com/darktable-org/darktable/releases/"
              "download/release-" version "/darktable-" version ".tar.xz"))
        (sha256
-        (base32 "167sdj8m3srj9h5hh9cf2kvfpp349sygkcdrfbjrqbnz9x1jh7f1"))))
+        (base32 "1hmcib37b5v8893d69i2qgvmbkmils8a0gn5dpg2462d43ijfjvj"))))
     (build-system cmake-build-system)
     (arguments
      (list
@@ -553,17 +554,6 @@  (define-public darktable
                  (string-append "\""
                                 (search-input-file inputs "/lib/libOpenCL.so")
                                 "\"")))))
-          (add-before 'configure 'prepare-build-environment
-            (lambda _
-              ;; Rawspeed fails to build with GCC due to OpenMP error:
-              ;; "undefined reference to `GOMP_loop_nonmonotonic_dynamic_next'"
-              (setenv "CC" "clang")
-              (setenv "CXX" "clang++")
-              ;; Darktable looks for opencl-c.h in the LLVM dir. Guix installs
-              ;; it to the Clang dir. We fix this by patching CMakeLists.txt.
-              (substitute* "CMakeLists.txt"
-                (("\\$\\{LLVM_INSTALL_PREFIX\\}")
-                 #$(this-package-native-input "clang")))))
           (add-before 'configure 'set-LDFLAGS
             (lambda _
               (setenv "LDFLAGS"
@@ -576,13 +566,12 @@  (define-public darktable
                   (,(string-append #$(this-package-input "gtk+")
                                    "/share/glib-2.0/schemas")))))))))
     (native-inputs
-     (list clang
-           cmocka
+     (list cmocka
            desktop-file-utils
+           gcc-13
            `(,glib "bin")
            gobject-introspection
            intltool
-           llvm                         ;should match the Clang version
            opencl-headers
            perl
            pkg-config