diff mbox series

[bug#68431,2/3] gnu: python-requests-kerberos: Fix build.

Message ID 87ttnh2j9g.fsf@troyfigiel.com
State New
Headers show
Series Fix python-requests-kerberos build | expand

Commit Message

Troy Figiel Jan. 13, 2024, 5:59 p.m. UTC
* gnu/packages/python-web.scm (python-requests-kerberos)[propagated-inputs]:
Add python-gssapi and python-krb5.
---
 gnu/packages/python-web.scm | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 567b01f396..e13716081f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3307,8 +3307,15 @@  (define-public python-requests-kerberos
                (base32
                 "1lbgjs779cjxhz07lfl9dbyp3qfh8a3ir2393042wfg518jd3afd"))))
     (build-system python-build-system)
-    (propagated-inputs (list python-cryptography python-pyspnego
-                             python-requests))
+    (propagated-inputs (list python-cryptography
+                             python-pyspnego
+                             python-requests
+
+                             ;; Required through pyspnego[kerberos]. Only
+                             ;; `python-krb5' is directly used in the source
+                             ;; code though.
+                             python-gssapi
+                             python-krb5))
     (home-page "https://github.com/requests/requests-kerberos")
     (synopsis "Kerberos authentication handler for python-requests")
     (description "This package provides a Kerberos authentication handler for