diff mbox series

[bug#69110] gnu: Add go-github-com-golang-jwt-jwt.

Message ID 87ttmcasvq.fsf@troyfigiel.com
State New
Headers show
Series [bug#69110] gnu: Add go-github-com-golang-jwt-jwt. | expand

Commit Message

Troy Figiel Feb. 13, 2024, 10:37 p.m. UTC
* gnu/packages/golang-crypto.scm (go-github-com-golang-jwt-jwt): New variable.
---
 gnu/packages/golang-crypto.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: ac470c516e19f194228edf9e348bdbc7fc10f97a

Comments

Sharlatan Hellseher Feb. 20, 2024, 12:01 a.m. UTC | #1
Hi,

I've adjusted package name and import path to follow go.mod
<https://github.com/golang-jwt/jwt/blob/v4.5.0/go.mod> and added v5
inherited from v4.

- name :: go-github-com-golang-jwt-jwt-v4
- import-path :: github.com/golang-jwt/jwt/v4

v4 pushed as 971b7b01c145535ea3da3cbe16622160e360140d,
v5 pusehd as 773d469a0eaa783d584fc9d2060df386fdc7aad8 to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 0dd43e0e03..4581f26c02 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -19,6 +19,7 @@ 
 ;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
 ;;; Copyright © 2023 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -426,6 +427,33 @@  (define-public go-github-com-gaukas-godicttls
 for values.")
     (license license:bsd-3)))
 
+(define-public go-github-com-golang-jwt-jwt
+  (package
+    (name "go-github-com-golang-jwt-jwt")
+    (version "4.5.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/golang-jwt/jwt")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1m7c9lwlmd0lnn0hyby1rb3f4nwn4xcjgca218frj0hi0krqn8kp"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/golang-jwt/jwt"))
+    (home-page "https://github.com/golang-jwt/jwt")
+    (synopsis "Go implementation of JSON Web Tokens")
+    (description
+     "This package provides a Go implementation of
+@url{https://datatracker.ietf.org/doc/html/rfc7519, JSON Web Tokens} and
+supports the parsing and verification as well as the generation and signing of
+JSON Web Tokens.  The currently supported signing algorithms are HMAC SHA,
+RSA, RSA-PSS, and ECDSA, though hooks are present for adding your own.")
+    (license license:expat)))
+
 (define-public go-github-com-gxed-hashland-keccakpg
   (let ((commit "d9f6b97f8db22dd1e090fd0bbbe98f09cc7dd0a8")
         (revision "0"))