[bug#76896,core-packages-team] gnu: minizip: Remove phase 'remove-crypt-h.

Message ID 87tt82ksw8.fsf@ngraves.fr
State New
Headers
Series [bug#76896,core-packages-team] gnu: minizip: Remove phase 'remove-crypt-h. |

Commit Message

Nicolas Graves March 9, 2025, 5:26 p.m. UTC
  During the update of glibc from 2.35 to 2.39, the crypt.h header has
been removed from glibc's include path.  Packages depending on this
header from minizip have no access to it anymore.  Remove this phase.

(I stumbled on that trying to package libkml, I don't know if I'll end
up sending the package (might not be needed and old), but I guess this
applies anyway).

* gnu/packages/compression.scm (minizip)[arguments]{phases}:
Delete 'remove-crypt-h phase.
---
 gnu/packages/compression.scm | 11 +----------
 1 file changed, 1 insertion(+), 10 deletions(-)
  

Patch

diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index df876f7373..8b4ff65cda 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -183,16 +183,7 @@  (define-public minizip
      `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'enter-source
-           (lambda _ (chdir "contrib/minizip") #t))
-         (add-after 'install 'remove-crypt-h
-           (lambda* (#:key outputs #:allow-other-keys)
-             ;; Remove <minizip/crypt.h> because it interferes with libc's
-             ;; <crypt.h> given that 'minizip.pc' says "-I…/include/minizip".
-             ;; Fedora does the same:
-             ;; <https://src.fedoraproject.org/rpms/zlib/c/4d2785ec3116947872f6f32dc4104e6d36d8a7a4?branch=master>.
-             (let ((out (assoc-ref outputs "out")))
-               (delete-file (string-append out "/include/minizip/crypt.h"))
-               #t))))))
+           (lambda _ (chdir "contrib/minizip"))))))
     (native-inputs
      (list autoconf automake libtool))
     (propagated-inputs (list zlib))