[bug#33920] gnu: gauche: Update to 0.9.7 - removed html doc.

Message ID 87sgxsvq9h.fsf@gmail.com
State Accepted
Headers show
Series [bug#33920] gnu: gauche: Update to 0.9.7 - removed html doc. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Gabriel Hondet Jan. 16, 2019, 10:41 a.m. UTC
Hello Pierre,

> I've noticed something strange however: in the description, you mention
> 
> --8<---------------cut here---------------start------------->8---
> There are currently 58 packages available.
> --8<---------------cut here---------------end--------------->8---
> 
> Isn't it shortsighted?  If another package is added upstream, then the
> description won't match anymore.
> 
> Why mentioning it at all?

Indeed, here is a new update patch without the number of packages.

* gnu/packages/scheme.scm (gauche): Update to 0.9.7 - removed html doc.
---
 gnu/packages/scheme.scm | 20 +++++++-------------
 1 file changed, 7 insertions(+), 13 deletions(-)

Comments

Pierre Neidhardt Jan. 16, 2019, 5:32 p.m. UTC | #1
Your patch does not only change the description but it also removes some
unnecessary code.

Is there a good reason it was added in the first place or was it simply a mistake?
Gabriel Hondet Jan. 16, 2019, 7:31 p.m. UTC | #2
On Wed 16 Jan 2019 at 18:32 Pierre Neidhardt wrote:

> Your patch does not only change the description but it also removes some
> unnecessary code.
>
> Is there a good reason it was added in the first place or was it simply a mistake?

It was a mistake (I first wanted to separate the outputs between doc and
out, thus the use of the ~outputs~ parameter in the lambdas; and then I
forgot to simplify the code).
Pierre Neidhardt Jan. 17, 2019, 7:29 a.m. UTC | #3
I've applied your patch with a minor change: "lambda*" to "lambda".

Thanks!

Patch

diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 48b52c7da..44d207f02 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1213,13 +1213,9 @@  The core is 12 builtin special forms and 33 builtin functions.")
                (("/bin/sh") (which "sh")))
              #t))
          (add-after 'build 'build-doc
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out")))
-               (with-directory-excursion "doc"
-                 (for-each
-                  (lambda (target)
-                    (invoke "make" target))
-                  '("info" "html" "htmls"))))
+           (lambda* _
+             (with-directory-excursion "doc"
+               (invoke "make" "info"))
              #t))
          (add-before 'check 'patch-normalize-test
            ;; neutralize sys-normalize-pathname test as it relies on
@@ -1235,10 +1231,9 @@  The core is 12 builtin special forms and 33 builtin functions.")
                (("binary net termios") "binary termios"))
              #t))
          (add-after 'install 'install-docs
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out")))
-               (with-directory-excursion "doc"
-                 (invoke "make" "install")))
+           (lambda* _
+             (with-directory-excursion "doc"
+               (invoke "make" "install"))
              #t)))))
     (synopsis "Scheme scripting engine")
     (description "Gauche is a R7RS Scheme scripting engine aiming at being a
@@ -1246,6 +1241,5 @@  handy tool that helps programmers and system administrators to write small to
 large scripts quickly.  Quick startup, built-in system interface, native
 multilingual support are some of the goals.  Gauche comes with a package
 manager/installer @code{gauche-package} which can download, compile, install
-and list gauche extension packages.  There are currently 58 packages
-available.")
+and list gauche extension packages.")
     (license bsd-3)))