bug#34994: [PATCH] gnu: Add emacs-ace-link.

Message ID 87sguhevad.fsf@gnu.org
State Accepted
Headers show
Series bug#34994: [PATCH] gnu: Add emacs-ace-link. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ludovic Courtès April 16, 2019, 5:04 p.m. UTC
mikadoZero <mikadozero@yandex.com> skribis:

>>From 88fa9952ab4ce2e8b9d77ca55fd93c9e70936d02 Mon Sep 17 00:00:00 2001
> From: mikadoZero <mikadozero@yandex.com>
> Date: Mon, 25 Mar 2019 19:39:09 -0400
> Subject: [PATCH] gnu: Add emacs-ace-link.
>
> * gnu/packages/emacs-xyz.scm (emacs-ace-link): New variable.

Applied with the tiny changes below, thanks!

Ludo’.

Comments

mikadoZero April 17, 2019, 10:03 p.m. UTC | #1
Thank you

Ludovic Courtès writes:

> mikadoZero <mikadozero@yandex.com> skribis:
>
>>>From 88fa9952ab4ce2e8b9d77ca55fd93c9e70936d02 Mon Sep 17 00:00:00 2001
>> From: mikadoZero <mikadozero@yandex.com>
>> Date: Mon, 25 Mar 2019 19:39:09 -0400
>> Subject: [PATCH] gnu: Add emacs-ace-link.
>>
>> * gnu/packages/emacs-xyz.scm (emacs-ace-link): New variable.
>
> Applied with the tiny changes below, thanks!
>
> Ludo’.
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 1161630b52..7aec695205 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -1161,9 +1161,9 @@ within a specified width.  It is useful for displaying long track titles.")
>      (home-page "https://github.com/abo-abo/ace-link")
>      (synopsis "Quickly follow links in Emacs")
>      (description
> -     "Currently, to jump to a link in a @file{Info-mode}, @file{help-mode},
> - @file{woman-mode}, @file{org-mode}, @file{eww-mode}, @file{compilation-mode},
> - @file{goto-address-mode} buffer, you can tab through the links to select the
> +     "Currently, to jump to a link in a @code{Info-mode}, @code{help-mode},
> +@code{woman-mode}, @code{org-mode}, @code{eww-mode}, @code{compilation-mode},
> +@code{goto-address-mode} buffer, you can tab through the links to select the
>  one you want.  This is an O(N) operation, where the N is the amount of links.
>  This package turns this into an O(1) operation.  It does so by assigning a
>  letter to each link using avy.")

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1161630b52..7aec695205 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1161,9 +1161,9 @@  within a specified width.  It is useful for displaying long track titles.")
     (home-page "https://github.com/abo-abo/ace-link")
     (synopsis "Quickly follow links in Emacs")
     (description
-     "Currently, to jump to a link in a @file{Info-mode}, @file{help-mode},
- @file{woman-mode}, @file{org-mode}, @file{eww-mode}, @file{compilation-mode},
- @file{goto-address-mode} buffer, you can tab through the links to select the
+     "Currently, to jump to a link in a @code{Info-mode}, @code{help-mode},
+@code{woman-mode}, @code{org-mode}, @code{eww-mode}, @code{compilation-mode},
+@code{goto-address-mode} buffer, you can tab through the links to select the
 one you want.  This is an O(N) operation, where the N is the amount of links.
 This package turns this into an O(1) operation.  It does so by assigning a
 letter to each link using avy.")