diff mbox series

bug#35854: [PATCH] lxqt: lxqt-panel: fix taskbar plugin's applicationlist issue.

Message ID 87sgt3sus0.fsf@gnu.org
State Accepted
Headers show
Series bug#35854: [PATCH] lxqt: lxqt-panel: fix taskbar plugin's applicationlist issue. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ludovic Courtès May 24, 2019, 4:05 p.m. UTC
Reza Alizadeh Majd <r.majd@pantherx.org> skribis:

> * gnu/packages/lxqt.scm (lxqt-panel): move `kwindowsystem` from `inputs`
> to `propagated-inputs`

Applied, but I added a comment based on your message (see below).  In
general, ‘propagated-inputs’ should be used only when strictly
necessary, so when we use them, it’s important to add comments
explaining why we do so.

Thanks for the patch!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index c3b25e5417..a8699b3d09 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -583,7 +583,9 @@  of other programs.")
        ("lxqt-build-tools" ,lxqt-build-tools)
        ("qttools" ,qttools)))
     (propagated-inputs
-      `(("kwindowsystem" ,kwindowsystem)))
+     ;; Propagating KWINDOWSYSTEM so that the list of opened applications
+     ;; shows up in lxqt-panel's taskbar plugin.
+     `(("kwindowsystem" ,kwindowsystem)))
     (arguments
      '(#:tests? #f                      ; no tests
        #:phases