diff mbox series

[bug#36713,6/6] Add emacs-mastodon.

Message ID 87sgr3snsc.fsf@zete.tk
State Accepted
Headers show
Series Add six Emacs packages. | expand

Commit Message

Jens Mølgaard July 18, 2019, 9:19 a.m. UTC
This adds emacs-mastodon, a mastodon client for emacs.

Comments

Brett Gilio July 28, 2019, 7:19 p.m. UTC | #1
Jens Mølgaard writes:

> This adds emacs-mastodon, a mastodon client for emacs.
>
> From 7d26310aad9bcfff9f6962f80d2cea6980509677 Mon Sep 17 00:00:00 2001
> From: =?UTF-8?q?Jens=20M=C3=B8lgaard?= <jens@zete.tk>
> Date: Thu, 18 Jul 2019 20:00:40 +1200
> Subject: [PATCH 6/6] gnu: Add emacs-mastodon.
>
> * gnu/packages/emacs-xyz.scm (emacs-mastodon): New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
>  1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index cbec471a9d..6c63a3c479 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -16714,3 +16714,35 @@ deleting words.  These goals were partly inspired by 750words.com where the
>  goal of the site is to encourage writing by setting a goal of 750 words at a
>  time.")
>      (license license:gpl3+)))
> +
> +(define-public emacs-mastodon
> +  (package
> +    (name "emacs-mastodon")
> +    (version "0.9.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/jdenen/mastodon.el.git")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "0hwax6y9dghqwsbnb6f1bnc7gh8xsh5cvcnayk2sn49x8b0zi5h1"))))
> +    (build-system emacs-build-system)
> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         ;; Move the source files to the top level, which is included in
> +         ;; the EMACSLOADPATH.
> +         (add-after 'unpack 'move-source-files
> +           (lambda _
> +             (let ((el-files (find-files "./lisp" ".*\\.el$")))
> +               (for-each (lambda (f)
> +                           (rename-file f (basename f)))
> +                         el-files))
> +             #t)))))
> +    (home-page "https://github.com/jdenen/mastodon.el")
> +    (synopsis "Emacs client for Mastodon")
> +    (description "@code{mastodon.el} is an Emacs client for Mastodon, the
> +federated microblogging social network.")
> +    (license license:gpl3+)))

Hi Jens,

Thank you for pushing this package to our repository. I am trying to use
it, but I am getting an issue that I can not replicate with other means
of acquiring the package. When
I try to use M-x mastodon, it gives me an usual error. Directly Git
cloning and loading it allows for it to work just fine.

Here is the issue.

https://github.com/jdenen/mastodon.el/issues/141

Because it is a known bug I dont know if it is something we can change
in our configuration. I am really interested in seeing if other people
can replicate the error using the Guix package

Thanks,
Brett Gilio
diff mbox series

Patch

From 7d26310aad9bcfff9f6962f80d2cea6980509677 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Jens=20M=C3=B8lgaard?= <jens@zete.tk>
Date: Thu, 18 Jul 2019 20:00:40 +1200
Subject: [PATCH 6/6] gnu: Add emacs-mastodon.

* gnu/packages/emacs-xyz.scm (emacs-mastodon): New variable.
---
 gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cbec471a9d..6c63a3c479 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16714,3 +16714,35 @@  deleting words.  These goals were partly inspired by 750words.com where the
 goal of the site is to encourage writing by setting a goal of 750 words at a
 time.")
     (license license:gpl3+)))
+
+(define-public emacs-mastodon
+  (package
+    (name "emacs-mastodon")
+    (version "0.9.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jdenen/mastodon.el.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0hwax6y9dghqwsbnb6f1bnc7gh8xsh5cvcnayk2sn49x8b0zi5h1"))))
+    (build-system emacs-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; Move the source files to the top level, which is included in
+         ;; the EMACSLOADPATH.
+         (add-after 'unpack 'move-source-files
+           (lambda _
+             (let ((el-files (find-files "./lisp" ".*\\.el$")))
+               (for-each (lambda (f)
+                           (rename-file f (basename f)))
+                         el-files))
+             #t)))))
+    (home-page "https://github.com/jdenen/mastodon.el")
+    (synopsis "Emacs client for Mastodon")
+    (description "@code{mastodon.el} is an Emacs client for Mastodon, the
+federated microblogging social network.")
+    (license license:gpl3+)))
-- 
2.22.0