diff mbox series

[bug#36638,v2,1/2] gnu: Add websocketpp.

Message ID 87sgr3g0mt.fsf@gnu.org
State Accepted
Headers show
Series [bug#36638,v2,1/2] gnu: Add websocketpp. | expand

Commit Message

Ludovic Courtès July 18, 2019, 9:20 a.m. UTC
Hi!

zerodaysfordays@sdf.lonestar.org (Jakob L. Kreuze) skribis:

> * gnu/packages/web.scm (websocketpp): New variable.

Applied with the minor changes below, in particular returning #t from
the build phase.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e61bbba695..f1083505ee 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -872,16 +872,15 @@  for efficient socket-like bidirectional reliable communication channels.")
     (build-system cmake-build-system)
     (inputs `(("boost" ,boost)
               ("openssl" ,openssl)))
-    (arguments '(#:configure-flags
-                 '("-DBUILD_TESTS=ON")
+    (arguments '(#:configure-flags '("-DBUILD_TESTS=ON")
                  #:phases
                  (modify-phases %standard-phases
                    (add-after 'install 'remove-tests
-                     (lambda* (#:key outputs
-                               #:allow-other-keys)
+                     (lambda* (#:key outputs #:allow-other-keys)
                        (let* ((install-dir (assoc-ref outputs "out"))
                               (bin-dir (string-append install-dir "/bin")))
-                         (delete-file-recursively bin-dir)))))))
+                         (delete-file-recursively bin-dir)
+                         #t))))))
     (home-page "https://www.zaphoyd.com/websocketpp/")
     (synopsis "C++ library implementing the WebSocket protocol")
     (description "WebSocket++ is a C++ library that can be used to implement