diff mbox series

[bug#40297] gnu: Add emacs-next-minimal.

Message ID 87sghs2fl6.fsf@asu.edu
State Accepted
Delegated to: Christopher Baines
Headers show
Series [bug#40297] gnu: Add emacs-next-minimal. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

John Soo March 29, 2020, 12:02 a.m. UTC
Hi Guix,

In preparation for the next emacs version I thought it would be good to
start adding "next" versions of some emacs packages. I added this for
proof-general, but there may be other needs for the minimal emacs for
version 27.

Thanks,

John

Comments

Christopher Baines Dec. 18, 2020, 10:57 a.m. UTC | #1
John Soo <jsoo1@asu.edu> writes:

> Hi Guix,
>
> In preparation for the next emacs version I thought it would be good to
> start adding "next" versions of some emacs packages. I added this for
> proof-general, but there may be other needs for the minimal emacs for
> version 27.

Hey John,

This seems OK to me, although I haven't used the emacs-next stuff.

I applied this patch, and built the package, but bin/emacs within the
package is empty, which means Emacs doesn't actually start.

→ ls -lh /gnu/store/nv9bk1l8292cvlvxm96q8bdkg36cdnc9-emacs-next-minimal-28.0.50-0.2ea3466/bin/emacs-28.0.50
-r-xr-xr-x 247 root root 0 Jan  1  1970 /gnu/store/nv9bk1l8292cvlvxm96q8bdkg36cdnc9-emacs-next-minimal-28.0.50-0.2ea3466/bin/emacs-28.0.50

Since it's taken so long for someone to get around to looking at this
patch, it's possible that this wasn't an issue back when you submitted
this.

Any ideas?

Thanks,

Chris
diff mbox series

Patch

>From 100e821af07716c463131acdb695bce630e2efa4 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 10:38:15 -0700
Subject: [PATCH] gnu: Add emacs-next-minimal.

* gnu/packages/emacs.scm (emacs-next-minimal): New variable.
---
 gnu/packages/emacs.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ec8de7373b..5d031b9695 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -20,6 +20,7 @@ 
 ;;; Copyright © 2019 Valentin Ignatev <valentignatev@gmail.com>
 ;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
 ;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
+;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -354,6 +355,34 @@  languages.")
     (native-inputs
      `(("pkg-config" ,pkg-config)))))
 
+(define-public emacs-next-minimal
+  (package
+    (inherit emacs-next)
+    (name "emacs-next-minimal")
+    (synopsis (package-synopsis emacs-minimal))
+    (build-system gnu-build-system)
+    (inputs
+     `(("jansson" ,jansson)
+       ("texinfo" ,texinfo)
+       ,@(package-inputs emacs-minimal)))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ,@(package-native-inputs emacs-minimal)))
+    (arguments
+     (substitute-keyword-arguments (package-arguments emacs-next)
+       ((#:modules _)
+        `((guix build emacs-utils)
+          ,@%gnu-build-system-modules))
+       ((#:imported-modules _)
+        `((guix build emacs-utils)
+          ,@%gnu-build-system-modules))
+       ((#:phases phases)
+        `(modify-phases ,phases
+           (delete 'install-site-start)
+           (delete 'restore-emacs-pdmp)))
+       ((#:configure-flags flags ''())
+        `(list "--with-gnutls=no" "--disable-build-details"))))))
+
 (define-public emacs-xwidgets
   (package
     (inherit emacs)
-- 
2.26.0