diff mbox series

[bug#40372] Add emacs-beancount

Message ID 87sghncqt4.fsf@dustycloud.org
State Accepted
Headers show
Series [bug#40372] Add emacs-beancount | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Christine Lemmer-Webber April 1, 2020, 12:51 p.m. UTC
Hot on the heels of beancount!

Also is able to inherit the beancount package in a really elegant way,
since it's installing a .el file from that.  Moments like this make me
say "I love Guix's delightful design!"

Comments

Ludovic Courtès April 2, 2020, 12:26 p.m. UTC | #1
Hello Chris!

Christopher Lemmer Webber <cwebber@dustycloud.org> skribis:

> Hot on the heels of beancount!
>
> Also is able to inherit the beancount package in a really elegant way,
> since it's installing a .el file from that.  Moments like this make me
> say "I love Guix's delightful design!"

Heheh.  :-)

> From 7fda36e4be1abc16a9855e13ee450927f0f0e25a Mon Sep 17 00:00:00 2001
> From: Christopher Lemmer Webber <cwebber@dustycloud.org>
> Date: Wed, 1 Apr 2020 08:48:25 -0400
> Subject: [PATCH] gnu: Add emacs-beancount.
>
> * gnu/packages/emacs-xyz.scm (emacs-beancount): New variable.

[...]

> +    (synopsis "Emacs mode for beancount")
> +    (description
> +      "Emacs mode for the beancount accounting tool.")))

Bonus points if you can turn that into a full sentence.  :-)

Otherwise LGTM, thank you!

Ludo’.
Christine Lemmer-Webber April 2, 2020, 3:20 p.m. UTC | #2
Ludovic Courtès writes:

> Hello Chris!
>
> Christopher Lemmer Webber <cwebber@dustycloud.org> skribis:
>
>> Hot on the heels of beancount!
>>
>> Also is able to inherit the beancount package in a really elegant way,
>> since it's installing a .el file from that.  Moments like this make me
>> say "I love Guix's delightful design!"
>
> Heheh.  :-)
>
>> From 7fda36e4be1abc16a9855e13ee450927f0f0e25a Mon Sep 17 00:00:00 2001
>> From: Christopher Lemmer Webber <cwebber@dustycloud.org>
>> Date: Wed, 1 Apr 2020 08:48:25 -0400
>> Subject: [PATCH] gnu: Add emacs-beancount.
>>
>> * gnu/packages/emacs-xyz.scm (emacs-beancount): New variable.
>
> [...]
>
>> +    (synopsis "Emacs mode for beancount")
>> +    (description
>> +      "Emacs mode for the beancount accounting tool.")))
>
> Bonus points if you can turn that into a full sentence.  :-)
>
> Otherwise LGTM, thank you!
>
> Ludo’.

Ok, done and pushed!  Thanks!
diff mbox series

Patch

From 7fda36e4be1abc16a9855e13ee450927f0f0e25a Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Wed, 1 Apr 2020 08:48:25 -0400
Subject: [PATCH] gnu: Add emacs-beancount.

* gnu/packages/emacs-xyz.scm (emacs-beancount): New variable.
---
 gnu/packages/emacs-xyz.scm | 21 ++++++++++++++++++++-
 1 file changed, 20 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ed3e6f15cd..f908a9f2a3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6,7 +6,7 @@ 
 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017, 2018, 2019 Chris Marusich <cmmarusich@gmail.com>
-;;; Copyright © 2015, 2016, 2018 Christopher Lemmer Webber <cwebber@dustycloud.org>
+;;; Copyright © 2015, 2016, 2018, 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2016 Adriano Peluso <catonano@gmail.com>
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
@@ -106,6 +106,7 @@ 
   #:use-module (gnu packages databases)
   #:use-module (gnu packages dictionaries)
   #:use-module (gnu packages emacs)
+  #:use-module (gnu packages finance)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages gnome)
@@ -22064,3 +22065,21 @@  conventions.")
       (description "Haskell-Snippets is a collection of YASnippet Haskell
 snippets for Emacs.")
       (license license:expat))))
+
+;; The beancount source ships with elisp in a subdirectory
+(define-public emacs-beancount
+  (package
+    (inherit beancount)
+    (name "emacs-beancount")
+    (build-system emacs-build-system)
+    (arguments
+     `(#:tests? #f ;no tests
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'chdir-emacs
+           (lambda _
+             (chdir "editors/emacs")
+             #t)))))
+    (synopsis "Emacs mode for beancount")
+    (description
+      "Emacs mode for the beancount accounting tool.")))
-- 
2.25.1