diff mbox series

[bug#41750] gnu: x265: Build with assembly files.

Message ID 87sgf6hmv7.fsf@rohleder.de
State Accepted
Headers show
Series [bug#41750] gnu: x265: Build with assembly files. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder June 7, 2020, 4:17 p.m. UTC
simple oneliner that made my ffmpeg encoding with hevc 3-4 times as fast.
also tested vlc build and decoding that video.

Comments

Efraim Flashner June 8, 2020, 10:03 a.m. UTC | #1
I thought this wasn't enabled due to it failing on aarch64 or armhf but
it turns out that wasn't the case. Patch pushed! Thanks.
diff mbox series

Patch

From 6fc19fa31df6c48e4118144fa3e0ecf738e45ce3 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sun, 7 Jun 2020 18:01:38 +0200
Subject: [PATCH] gnu: x265: Build with assembly files.

* gnu/packages/video.scm (x265): Build with assembly files.
---
 gnu/packages/video.scm | 1 +
 1 file changed, 1 insertion(+)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8d9d5ecfd1..c822075c57 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -625,6 +625,7 @@  available.")
                     (delete-file-recursively "source/compat/getopt")
                     #t))))
     (build-system cmake-build-system)
+    (native-inputs `(("nasm" ,nasm)))
     (arguments
      `(#:tests? #f ; tests are skipped if cpu-optimized code isn't built
        #:configure-flags
-- 
2.26.2