diff mbox series

[bug#41892] Update crawl to 0.25.0

Message ID 87sgevcfyg.fsf@dustycloud.org
State Accepted
Headers show
Series [bug#41892] Update crawl to 0.25.0 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Christine Lemmer-Webber June 16, 2020, 1:12 p.m. UTC
Patch attached.  The new version of Crawl is amazing.  Completely
reworked spell system and everything!

However, apparently the -nodeps.tar.xz release is normally made before
the Debian release... since I expressed interest in packaging 0.25.0
asap one of the devs made the tarball themselves, but apparently from an
OSX machine, and it left all these ._* doodads in it, which broke
compilation.  I added a couple of lines to get rid of them.

I'm not sure if they're going to release another tarball that removes
those; I guess if they do, that'll have a different hash.  In the
meanwhile this does work.

I'm not sure if I should push it or not given the above.  Maybe we
should wait to see if the dev responds to me on IRC about the ._* files.
(Apparently after the tournament is done, a 0.25.1 release is likely
soon anyway.)

 - Chris

Comments

Ricardo Wurmus June 16, 2020, 3:31 p.m. UTC | #1
Christopher Lemmer Webber <cwebber@dustycloud.org> writes:

> Patch attached.  The new version of Crawl is amazing.  Completely
> reworked spell system and everything!

This looks good to me.

> I'm not sure if I should push it or not given the above.  Maybe we
> should wait to see if the dev responds to me on IRC about the ._* files.

I think it’s fine.  That’s one of the use cases for snippets.
Christine Lemmer-Webber June 16, 2020, 7:07 p.m. UTC | #2
Ricardo Wurmus writes:

> Christopher Lemmer Webber <cwebber@dustycloud.org> writes:
>
>> Patch attached.  The new version of Crawl is amazing.  Completely
>> reworked spell system and everything!
>
> This looks good to me.
>
>> I'm not sure if I should push it or not given the above.  Maybe we
>> should wait to see if the dev responds to me on IRC about the ._* files.
>
> I think it’s fine.  That’s one of the use cases for snippets.

Ok!  It's pushed then.

(If someone notices that the hash becomes mismatched, it's probably
because the source did a re-upload removing those files... I don't know
if they will; haven't heard as such.)
diff mbox series

Patch

From 288f754bded0d4c306b3b29e1f8d11a90516b48f Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Tue, 16 Jun 2020 09:06:20 -0400
Subject: [PATCH] gnu: crawl: Update to 0.25.0.

* gnu/packages/games.scm (crawl): Update to 0.25.0.
---
 gnu/packages/games.scm | 16 +++++++++++++---
 1 file changed, 13 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 10ac8cb550..e95effa992 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5264,7 +5264,7 @@  fish.  The whole game is accompanied by quiet, comforting music.")
 (define-public crawl
   (package
     (name "crawl")
-    (version "0.24.0")
+    (version "0.25.0")
     (source
      (origin
        (method url-fetch)
@@ -5277,8 +5277,18 @@  fish.  The whole game is accompanied by quiet, comforting music.")
              (string-append "http://crawl.develz.org/release/stone_soup-"
                             version "-nodeps.tar.xz")))
        (sha256
-        (base32 "0kdq6s12myxfdg75ma9x3ys2nd0xwb3xm2ynlmhg4628va0pnixr"))
-       (patches (search-patches "crawl-upgrade-saves.patch"))))
+        (base32 "0rn1wjxdqw33caiwisfypm1j8cid3c9pz01ahicl17144zs29z3d"))
+       (patches (search-patches "crawl-upgrade-saves.patch"))
+       ;; The 0.25.0 -nodeps.tar.xz was built from an OSX machine; normally
+       ;; apparently it's built from a Debian machine before the Debian
+       ;; packages are made.  These ._* files are binary and have the string
+       ;; "Mac OS X" in them... removing these seems to result in compilation
+       ;; again.
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           (for-each delete-file (find-files "." "^\\._"))
+           #t))))
     (build-system gnu-build-system)
     (inputs
      `(("lua51" ,lua-5.1)
-- 
2.26.2