diff mbox series

[bug#42616] gnu: python2-setproctitle: fix build.

Message ID 87sgd9e9vh.fsf@rohleder.de
State Accepted
Headers show
Series [bug#42616] gnu: python2-setproctitle: fix build. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder July 30, 2020, 7:32 a.m. UTC
python2-setproctitle fails in test phase, because the "--embed"
parameter should not be used for python-config, but for python3-config,
it seems.

Comments

vasilii.smirnov--- via Guix-patches" via July 30, 2020, 10:10 a.m. UTC | #1
Michael Rohleder 写道:
> python2-setproctitle fails in test phase, because the "--embed"
> parameter should not be used for python-config, but for 
> python3-config,
> it seems.

Indeed.  Pushed with tweaked commit message as 
39386de24439c81f1a7c683ae8c5dd1c5f24e09e.

Thanks!

T G-R
diff mbox series

Patch

From be8c9241a3dd2d9cf180ec82d787e891731b70e4 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Thu, 30 Jul 2020 09:22:22 +0200
Subject: [PATCH] gnu: python2-setproctitle: fix build.

* gnu/packages/python-xyz.scm (python2-setproctitle): fix build.
---
 gnu/packages/python-xyz.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0b33fb3a4c..a5c2e60ce4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13529,9 +13529,9 @@  English stemmer.")
          (replace 'check
            (lambda _
              (setenv "PYTHON" (or (which "python3") (which "python")))
-             (setenv "PYCONFIG" (string-append (or (which "python3-config")
-                                                   (which "python-config"))
-                                               " --embed"))
+             (setenv "PYCONFIG" (if (which "python3-config")
+                                    "python3-config --embed"
+                                    "python-config"))
              (setenv "CC" "gcc")
              ;; No need to extend PYTHONPATH to find the built package, since
              ;; the Makefile will build anyway
-- 
2.27.0