diff mbox series

[bug#43722] Add emacs-gcmh package

Message ID 87sgazgzao.fsf@posteo.net
State Accepted
Headers show
Series [bug#43722] Add emacs-gcmh package | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Niklas Eklund Sept. 30, 2020, 1:38 p.m. UTC
Add package that alters the garbage collection strategy in Emacs.

Comments

Niklas Eklund Sept. 30, 2020, 3:59 p.m. UTC | #1
retitle 43722
Nicolas Goaziou Oct. 1, 2020, 12:32 p.m. UTC | #2
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

> * gnu/packages/emacs-xyz.scm (emacs-gcmh): New variable.

Thank you.

Some comments follow.

> +(define-public emacs-gcmh
> +  (let ((commit "84c43a4c0b41a595ac6e299fa317d2831813e580")
> +        (revision "0"))

Could you add a comment explaining why we're providing a specific commit
instead of a tagged release?

> +    (package
> +      (name "emacs-gcmh")
> +      (version (git-version "0.1" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://gitlab.com/koral/gcmh")
> +               (commit commit)))
> +         (sha256
> +          (base32 "1r3wiqhrzh7wvqy484nl031fd4bn4cpvkv9646s4cjgvnnnv7jz3"))
> +         (file-name (git-file-name name version))))
> +      (build-system emacs-build-system)
> +      (home-page "https://gitlab.com/koral/gcmh")
> +      (synopsis
> +       "The GNU Emacs Garbage Collector Magic Hack")

The string should be moved on the same line as `synopsis'. Also:

  Emacs Garbage Collector Magic Hack

is enough.

> +      (description
> +       "This package enforces a sneaky Garbage Collection strategy to minimize

I suggest 

  ... a sneaky @dfn{garbage collector} (GC) strategy to minimize...

Could you send an updated patch?

Regards,
diff mbox series

Patch

From 0f7a1a461f99462276087c872479c3aafa0c12a4 Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Wed, 30 Sep 2020 15:34:36 +0200
Subject: [PATCH] gnu: Add emacs-gcmh.

* gnu/packages/emacs-xyz.scm (emacs-gcmh): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 13471f77d1..25b37d57c8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1768,6 +1768,31 @@  always indented.  It reindents after every change, making it more reliable
 than @code{electric-indent-mode}.")
     (license license:gpl2+)))
 
+(define-public emacs-gcmh
+  (let ((commit "84c43a4c0b41a595ac6e299fa317d2831813e580")
+        (revision "0"))
+    (package
+      (name "emacs-gcmh")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://gitlab.com/koral/gcmh")
+               (commit commit)))
+         (sha256
+          (base32 "1r3wiqhrzh7wvqy484nl031fd4bn4cpvkv9646s4cjgvnnnv7jz3"))
+         (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (home-page "https://gitlab.com/koral/gcmh")
+      (synopsis
+       "The GNU Emacs Garbage Collector Magic Hack")
+      (description
+       "This package enforces a sneaky Garbage Collection strategy to minimize
+GC interference with the activity.  During normal use a high GC threshold is
+set.  When idling GC is immediately triggered and a low threshold is set.")
+      (license license:gpl3+))))
+
 (define-public emacs-ctrlf
   (package
     (name "emacs-ctrlf")
-- 
2.28.0