diff mbox series

[bug#44019] add dbus-cxx

Message ID 87sga5hv8v.fsf@gmail.com
State Accepted
Headers show
Series [bug#44019] add dbus-cxx | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Miguel Arruga Vivas Oct. 23, 2020, 2:28 p.m. UTC
Hi,

tiregram arthur <ruhtra.mar@gmail.com> writes:
>> update.
>> i remove newline.
>> i move to tar
>> i add compilation option for test, tools and glibmm
>> i modified description
>> i indent the code as expected.
>>
>> you can find the new version atach to this email.

Thank you very much, this version looks superb! :-)

> I just get the warning about softwareheritage.
> Who is in charge of this part?

I still need an answer for this.  As soon as I have it, I hope sooner
than later, I'll push this with the right origin, as you provided both
versions already.

Thank you again,
Miguel

---
From e3dcfc10dcd9fff1486b282b3d77309411c44ac9 Mon Sep 17 00:00:00 2001
From: ruhtra <ruhtra.mar@gmail.com>
Date: Fri, 23 Oct 2020 14:40:20 +0200
Subject: [PATCH] gnu: Add dbus-cxx.

---
 gnu/packages/glib.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

Comments

Miguel Arruga Vivas Oct. 24, 2020, 1:02 a.m. UTC | #1
Hi again,

Miguel Ángel Arruga Vivas <rosen644835@gmail.com> writes:
> I still need an answer for this.  As soon as I have it, I hope sooner
> than later, I'll push this with the right origin, as you provided both
> versions already.

I've been checking this thread[1] and I've decided to keep url-fetch for
consistency inside the same file.

It has been pushed to master[2] with the indentation proposed by
etc/indent-code.el and a minor change there:

> +     (inputs `(("dbus-glib" ,dbus)

I changed the name of the input from "dbus-glib" (that it's a different
library in the same file) to "dbus".

Again, thank you very much for your contribution. :-)

Happy hacking!
Miguel

[1] https://lists.gnu.org/archive/html/guix-devel/2020-05/msg00224.html and
[2] https://git.savannah.gnu.org/cgit/guix.git/commit/?id=4fbd3c36c6a6db8fc648ecdcc612c0e14a55a523.
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index cde95b13eb..898b44a9e4 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -13,6 +13,7 @@ 
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2020 Arthur Margerit <ruhtra.mar@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -53,6 +54,7 @@ 
   #:use-module (gnu packages package-management)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages perl-check)
+  #:use-module (gnu packages popt)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
@@ -61,6 +63,7 @@ 
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
@@ -932,6 +935,45 @@  programming language.  It also contains the utility
     (home-page "https://sourceforge.net/projects/dbus-cplusplus/")
     (license license:lgpl2.1+)))
 
+(define-public dbus-cxx
+  (package
+    (name "dbus-cxx")
+    (version "0.12.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/dbus-cxx/dbus-cxx/"
+                                  version "/dbus-cxx-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1acsgpkd9v7b9jdc79ijmh9dbdfrzgkwkaff518i3zpk7y6g5mzw"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags '("-DENABLE_TESTS=ON"
+                           "-DENABLE_TOOLS=ON"
+                           "-DENABLE_GLIBMM=ON")))
+     (inputs `(("dbus-glib" ,dbus)
+               ("libsigc++" ,libsigc++)
+               ("glibmm" ,glibmm)
+               ("python" ,python)
+               ("popt" ,popt)
+               ("expat" ,expat)))
+     (native-inputs `(("pkg-config" ,pkg-config)
+                      ("m4" ,m4)))
+    (synopsis "C++ wrapper for dbus")
+    (description "Dbus-cxx is a C++ wrapper for dbus.\n
+It exposes the C API to allow direct manipulation and
+relies on sigc++ to provide an Oriented Object interface.\n
+This package provide 2 utils:
+@enumerate
+@item @command{dbus-cxx-xml2cpp} to generate proxy and adapter
+@item @command{dbus-cxx-introspect} to introspect a dbus interface
+@end enumerate
+
+Some codes examples can be find at:
+@url{https://dbus-cxx.github.io/examples.html}")
+    (home-page "https://dbus-cxx.github.io/")
+    (license license:gpl3)))
+
 (define-public appstream-glib
   (package
     (name "appstream-glib")