diff mbox series

[bug#45153,v2] gnu: rottlog: Fix mail reporting.

Message ID 87sg7wwoo4.fsf@gnu.org
State Accepted
Headers show
Series [bug#45153,v2] gnu: rottlog: Fix mail reporting. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ludovic Courtès Dec. 23, 2020, 3:02 p.m. UTC
Hi!

John Doe <dftxbs3e@free.fr> skribis:

> From: Léo Le Bouter <lle-bout@zaclys.net>
>
> * gnu/packages/admin.scm (rottlog):
> [inputs]: Add sendmail.
> [phases]: Modify 'patch-paths to substitute sendmail command with
> /gnu/store item.

[...]

> +                        (("/usr/sbin/sendmail")
> +                         (string-append (assoc-ref inputs "sendmail")
> +                                        "/usr/sbin/sendmail")))

I thought this was a typo and then realized that our ‘sendmail’ package
is this broken, due to an incorrect use of ‘DESTDIR’.

The patch below is an attempt to fix that but some of the files are
silently not getting installed.  Anyone has ideas here?

Anyhow, can we instead use ‘mail’ from ‘mailutils’ instead?  (I
wrongfully mentioned Inetutils earlier, sorry for the confusion.)

Thanks,
Ludo’.

Comments

Léo Le Bouter Dec. 23, 2020, 3:19 p.m. UTC | #1
On Wed, 2020-12-23 at 16:02 +0100, Ludovic Courtès wrote:
> Hi!

Hello!

> I thought this was a typo and then realized that our ‘sendmail’
> package
> is this broken, due to an incorrect use of ‘DESTDIR’.

Ah! Well I did not notice that as something wrong outright but now that
you say that yes I see the correct behavior :-)

> The patch below is an attempt to fix that but some of the files are
> silently not getting installed.  Anyone has ideas here?

Will take a look!

> Anyhow, can we instead use ‘mail’ from ‘mailutils’ instead?  (I
> wrongfully mentioned Inetutils earlier, sorry for the confusion.)

Is it going to be compatible? If so then I'll do it!

> Thanks,
> Ludo’.

Thank *you*! :-)
Ludovic Courtès Dec. 27, 2020, 3:07 p.m. UTC | #2
Hi,

Leo Le Bouter <lle-bout@zaclys.net> skribis:

>> I thought this was a typo and then realized that our ‘sendmail’
>> package
>> is this broken, due to an incorrect use of ‘DESTDIR’.
>
> Ah! Well I did not notice that as something wrong outright but now that
> you say that yes I see the correct behavior :-)
>
>> The patch below is an attempt to fix that but some of the files are
>> silently not getting installed.  Anyone has ideas here?
>
> Will take a look!

Great.

>> Anyhow, can we instead use ‘mail’ from ‘mailutils’ instead?  (I
>> wrongfully mentioned Inetutils earlier, sorry for the confusion.)
>
> Is it going to be compatible? If so then I'll do it!

Yes, I think so, again provided there’s a mail setup on the machine.

I went ahead and made this change since it was a minor change compared
to the patch you had sent earlier.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index f85713433e..1f06450e6a 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2759,23 +2759,39 @@  powerful user customization features.")
                (("SHELL=/bin/sh") (string-append "SHELL=" (which "sh"))))
              #t))
          (replace 'configure
-           (lambda _
+           (lambda* (#:key outputs #:allow-other-keys)
 
              ;; Render harmless any attempts to chown or chgrp
              (substitute* "devtools/bin/install.sh"
                (("owner=\\$2") "owner=''")
                (("group=\\$2") "group=''"))
 
-             (with-output-to-file "devtools/Site/site.config.m4"
-               (lambda ()
-                 (format #t "
+             (let ((out (assoc-ref outputs "out")))
+               (with-output-to-file "devtools/Site/site.config.m4"
+                 (lambda ()
+                   ;; See 'devtools/M4/UNIX/defines.m4' for the list of
+                   ;; installation directories.
+                   (format #t "
 define(`confCC', `gcc')
 define(`confOPTIMIZE', `-g -O2')
 define(`confLIBS', `-lresolv')
 define(`confINSTALL', `~a/devtools/bin/install.sh')
 define(`confDEPEND_TYPE', `CC-M')
 define(`confINST_DEP', `')
-" (getcwd))))
+
+define(`confMBINDIR', `~a/bin')
+define(`confUBINDIR', `~a/bin')
+define(`confSBINDIR', `~a/sbin')
+define(`confEBINDIR', `~a/libexec')
+define(`confMANROOT', `~a/share/man')~%"
+                           (getcwd)
+                           out out out out out))))
+
+             (substitute* "cf/cf/Makefile"
+               (("^MAILDIR=.*")
+                (string-append "MAILDIR = "
+                               (assoc-ref outputs "out")
+                               "/etc/mail\n")))
              #t))
          (replace 'build
            (lambda _
@@ -2787,10 +2803,9 @@  define(`confINST_DEP', `')
          (add-before 'install 'pre-install
            (lambda _
              (let ((out (assoc-ref %outputs "out")))
-               (mkdir-p (string-append out "/usr/bin"))
-               (mkdir-p (string-append out "/usr/sbin"))
+               (mkdir-p (string-append out "/bin"))
+               (mkdir-p (string-append out "/sbin"))
                (mkdir-p (string-append out "/etc/mail"))
-               (setenv "DESTDIR" out)
                (with-directory-excursion "cf/cf"
                  (invoke "sh" "Build" "install-cf"))
                #t))))