diff mbox series

[bug#47447,v2] gnu: Add entt.

Message ID 87sg42mjl9.fsf@posteo.ro
State Accepted
Headers show
Series [bug#47447,v2] gnu: Add entt. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Alexandru-Sergiu Marton April 7, 2021, 11:15 a.m. UTC
I wrote:

> Leo Prikler writes:
>
>> Would it be possible to cherry-pick this commit and add it to the
>> patches field of entt's origin?
>
> I'm inexperienced with cherry-picking. I will try to do it, but the
> maintainer mentioned another release might come soon, so if that happens
> before I get to figure this out, I will come back with a recipe for the
> new version which will contain the fixed tests too.

The new release indeed came and after a discussion with the maintainer I
managed to get all the tests running too. I'm attaching the a new patch
with the lastest version to this email.

Cheers.

Comments

Leo Prikler April 7, 2021, 11:46 a.m. UTC | #1
Hello,
Am Mittwoch, den 07.04.2021, 14:15 +0300 schrieb Alexandru-Sergiu
Marton:
> The new release indeed came and after a discussion with the
> maintainer I
> managed to get all the tests running too. I'm attaching the a new
> patch
> with the lastest version to this email.
> 
> Cheers.
Thanks!  I've applied some small cosmetic changes, moved the package to
game-development.scm (where I feel it would fit better) and pushed it
to master.

Regards,
Leo
diff mbox series

Patch

From ff79e8c2a8f70cde214a10091747f8e2ae8db052 Mon Sep 17 00:00:00 2001
From: Alexandru-Sergiu Marton <brown121407@posteo.ro>
Date: Sun, 28 Mar 2021 12:56:53 +0300
Subject: [PATCH v2] gnu: Add entt.

* gnu/packages/cpp.scm (entt): New variable.
---
 gnu/packages/cpp.scm | 34 +++++++++++++++++++++++++++++++++-
 1 file changed, 33 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 2a00d3838a..be9aa5ff30 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -18,7 +18,7 @@ 
 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2020 Milkey Mouse <milkeymouse@meme.institute>
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
-
+;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -57,6 +57,7 @@ 
   #:use-module (gnu packages curl)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages gcc)
+  #:use-module (gnu packages graphviz)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libunwind)
   #:use-module (gnu packages linux)
@@ -1211,3 +1212,34 @@  of reading and writing XML.")
     ;; incompatible with the GPL v2.  Refer to the file named FLOSSE for the
     ;; details.
     (license license:gpl2+)))
+
+(define-public entt
+  (package
+    (name "entt")
+    (version "3.7.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/skypjack/entt")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0nzvnhiw3r6nkmxp749zwxc8kzja09nijyxibdbri3g2i7pysf58"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags (list "-DENTT_BUILD_TESTING=ON"
+                               "-DENTT_FIND_GTEST_PACKAGE=ON"
+                               "-DENTT_BUILD_DOCS=ON")
+       #:build-type "Debug")) ;; Only tests are compiled; this is needed so
+                              ;; that assertions work.
+    (native-inputs
+     `(("googletest" ,googletest)
+       ("doxygen" ,doxygen)     ; These two packages are needed for
+       ("graphviz" ,graphviz))) ; generating the documentation.
+    (synopsis "Fast and reliable entity component system (ECS)")
+    (description "EnTT is a header-only, tiny and easy to use library for game
+programming and much more written in modern C++.")
+    (home-page "https://github.com/skypjack/entt")
+    (license (list license:expat        ; for the code
+                   license:cc-by4.0)))) ; for the docs
-- 
2.31.0