diff mbox series

bug#47519: [PATCH] gnu: Add galera.

Message ID 87sg408o2e.fsf@gnu.org
State Accepted
Headers show
Series bug#47519: [PATCH] gnu: Add galera. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès April 8, 2021, 9:27 p.m. UTC
Hi David,

david larsson <david.larsson@selfhosted.xyz> skribis:

> From 6df0f4b43623689ba7e954174c775d37cc1f5f04 Mon Sep 17 00:00:00 2001
> From: methuselah-0 <david.larsson@selfhosted.xyz>
> Date: Wed, 31 Mar 2021 12:38:50 +0200
> Subject: [PATCH] gnu: Add galera.
>
> * gnu/packages/databases.scm (galera): New variable.

Applied with the minor changes below.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index fc0273162a..8c657e4113 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1011,21 +1011,22 @@  developed in C/C++ to MariaDB and MySQL databases.")
               (method git-fetch)
               (uri (git-reference
                     (commit "bac8171266cb982fe013ce496d78085438c6f23e")
-                    (url "https://github.com/codership/galera.git")
+                    (url "https://github.com/codership/galera")
                     (recursive? #t)))
+              (file-name (git-file-name name version))
               (sha256
                (base32 "0h7s670pcasq8wzprhyxqfca2cghi62b8xz2kikb2a86wd453qil"))))
     (build-system cmake-build-system)
-    (native-inputs
+    (inputs
      `(("check" ,check)
-       ("boost" ,boost)))
-    (inputs
-     `(("openssl" ,openssl)))
+       ("boost" ,boost)
+       ("openssl" ,openssl)))
     (home-page "https://github.com/codership/galera/")
     (synopsis "Extension to the MariaDB database server")
     (description
-     "Galera is a wsrep-provider that is used with MariaDB for load-balancing and HA.")
-    (license license:gpl2)))
+     "Galera is a wsrep-provider that is used with MariaDB for load-balancing
+and high-availability (HA).")
+    (license license:gpl2)))                  ;'COPYING' says "version 2" only
 
 ;; Don't forget to update the other postgresql packages when upgrading this one.
 (define-public postgresql-13