diff mbox series

[bug#50156] gnu: emacs-vertico: Add new phase after unpack.

Message ID 87sfz24fzi.fsf@posteo.org
State Accepted
Headers show
Series [bug#50156] gnu: emacs-vertico: Add new phase after unpack. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Aleksandr Vityazev Aug. 21, 2021, 9:58 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-vertico)[arguments]<phases>:
After the unpack phase add a move-source-files phase.
---
 gnu/packages/emacs-xyz.scm | 12 ++++++++++++
 1 file changed, 12 insertions(+)

Comments

Brice Waegeneire Aug. 26, 2021, 8:05 p.m. UTC | #1
Hello Alexandr,

Thank you for the patch, it has been pushed as
b4d132f98e03fae559db832e88897f1e166c4d47.

Cheers,
- Brice
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bea6288976..27029b2977 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29166,6 +29166,18 @@  and preferred services can easily be configured.")
        (sha256
         (base32 "0rddk76ih44b574lsr6d6r9wa2l7c9zlb9kcyw5xvly17ciiq16h"))))
     (build-system emacs-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; Move the extensions source files to the top level, which is included in
+         ;; the EMACSLOADPATH.
+         (add-after 'unpack 'move-source-files
+           (lambda _
+             (let ((el-files (find-files "./extensions" ".*\\.el$")))
+               (for-each (lambda (f)
+                           (rename-file f (basename f)))
+                         el-files))
+             #t)))))
     (native-inputs
      `(("texinfo" ,texinfo)))
     (home-page "https://github.com/minad/vertico")