diff mbox series

[bug#50341,1/1] gnu: Update emacs-org-roam to include extensions

Message ID 87sfync4s5.fsf@rekahsoft.ca
State Accepted
Headers show
Series emacs-org-roam include extensions | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Collin J. Doering Sept. 2, 2021, 4:36 p.m. UTC
---
 gnu/packages/emacs-xyz.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Collin J. Doering Sept. 2, 2021, 4:48 p.m. UTC | #1
Noticed that this duplicates (https://issues.guix.gnu.org/50333),
however in 50333, another build phase is added to copy over extensions
which is not necessary give the #:include option (as used in the patchset).

On 02 Sep 2021 at 12:36, "Collin J. Doering" <collin@rekahsoft.ca> wrote:

> ---
>  gnu/packages/emacs-xyz.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index c106e81fa5..bb6d0b0757 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -28232,7 +28232,8 @@ snippets for Emacs.")
>          (base32 "092xn0sqc7b7f6pdf7m6c3giqqbh6fq02mfz8qrg0wmx4ds1isqp"))))
>      (build-system emacs-build-system)
>      (arguments
> -     `(#:phases
> +     `(#:include (cons "^extensions/" %default-include)
> +       #:phases
>         (modify-phases %standard-phases
>           (add-after 'install 'install-image
>             (lambda* (#:key outputs #:allow-other-keys)
> -- 
> 2.33.0
Collin J. Doering Sept. 3, 2021, 2:25 p.m. UTC | #2
I realized this morning that this change, unlike
https://issues.guix.gnu.org/50333 does not copy extensions into the
load-path that will be used, which is certainly not favorable.

I think that longer term we likely want to have a separate package that
includes these org-roam extensions.

Closing this issue in preference of 50333.

On 02 Sep 2021 at 12:48, "Collin J. Doering" <collin@rekahsoft.ca> wrote:

> Noticed that this duplicates (https://issues.guix.gnu.org/50333),
> however in 50333, another build phase is added to copy over extensions
> which is not necessary give the #:include option (as used in the patchset).
>
> On 02 Sep 2021 at 12:36, "Collin J. Doering" <collin@rekahsoft.ca> wrote:
>
>> ---
>>  gnu/packages/emacs-xyz.scm | 3 ++-
>>  1 file changed, 2 insertions(+), 1 deletion(-)
>>
>> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
>> index c106e81fa5..bb6d0b0757 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -28232,7 +28232,8 @@ snippets for Emacs.")
>>          (base32 "092xn0sqc7b7f6pdf7m6c3giqqbh6fq02mfz8qrg0wmx4ds1isqp"))))
>>      (build-system emacs-build-system)
>>      (arguments
>> -     `(#:phases
>> +     `(#:include (cons "^extensions/" %default-include)
>> +       #:phases
>>         (modify-phases %standard-phases
>>           (add-after 'install 'install-image
>>             (lambda* (#:key outputs #:allow-other-keys)
>> -- 
>> 2.33.0
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c106e81fa5..bb6d0b0757 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28232,7 +28232,8 @@  snippets for Emacs.")
         (base32 "092xn0sqc7b7f6pdf7m6c3giqqbh6fq02mfz8qrg0wmx4ds1isqp"))))
     (build-system emacs-build-system)
     (arguments
-     `(#:phases
+     `(#:include (cons "^extensions/" %default-include)
+       #:phases
        (modify-phases %standard-phases
          (add-after 'install 'install-image
            (lambda* (#:key outputs #:allow-other-keys)