diff mbox series

bug#51287: [PATCH] gnu: packages: Add python-ijson

Message ID 87sfwisg0q.fsf@gnu.org
State Accepted
Headers show
Series bug#51287: [PATCH] gnu: packages: Add python-ijson | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès Oct. 30, 2021, 3:12 p.m. UTC
Hi,

Raphaël Mélotte <raphael.melotte@mind.be> skribis:

> * gnu/packages/python-xyz.scm (python-ijson): New variable.

Applied with the following changes to placate ‘guix lint’ and improve
synopsis/description.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f4edc1e49f..f12cca9757 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27626,15 +27626,19 @@  (define-public python-ijson
          ;; anyway, so use pytest to avoid running the yajl1-related
          ;; tests. See: https://github.com/ICRAR/ijson/issues/55
          (replace 'check
-           (lambda _ (invoke "pytest" "-vv"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest" "-vv")))))))
     (inputs
      ;; libyajl is optional, but compiling with it makes faster
      ;; backends available to ijson:
-     `(("libyajl", libyajl)
-       ("python-pytest", python-pytest)))
+     `(("libyajl", libyajl)))
+    (native-inputs
+     `(("python-pytest", python-pytest)))
     (build-system python-build-system)
     (home-page "https://github.com/ICRAR/ijson")
-    (synopsis "Iterative JSON parser with standard Python iterator interfaces")
+    (synopsis "Iterative JSON parser with Python iterator interfaces")
     (description
-     "Iterative JSON parser with standard Python iterator interfaces")
+     "Ijson is an iterative JSON parser with standard Python iterator
+interfaces.")
     (license license:bsd-3)))