diff mbox series

[bug#55929] gnu: maven: Add maven-doxia-sink-api

Message ID 87sfo1vris.fsf@gmail.com
State Accepted
Headers show
Series [bug#55929] gnu: maven: Add maven-doxia-sink-api | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov June 18, 2022, 4:57 p.m. UTC
Oh sorry, it happens to me every now and then.

Here's the right one.
- Artyom

Comments

Julien Lepiller June 18, 2022, 6 p.m. UTC | #1
Thanks for the new patch :)

Le Sat, 18 Jun 2022 19:57:15 +0300,
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> a écrit :

> +    (native-inputs
> +     (list java-javax-inject))
> +    (propagated-inputs
> +     (list maven-parent-pom-34))

Sorry if my previous messages were confusing you. I meant to have a new
package maven-doxia-parent (or similar name) that contains only the
parent pom file. You're propagating the grand-parent. I think this
would be more correct:

(propagated-inputs (list maven-doxia-parent))

and maven-doxia-parent would be something like:

(define maven-doxia-parent
  (package
    (inherit maven-doxia-sink-api)
    (name "maven-doxia-parent")
    (arguments
     `(#:tests? #f
       #:phases
       (modify-phases %standard-phases
         (delete 'configure)
         (delete 'build)
         (replace 'install (install-pom-file "pom.xml")))))
    (synopsis "...")
    (description "...")))

This is untested, of course :)

Since we "define" and not "define-public" (we don't want it to be
accessible from other modules or the command-line), you can put both
packages in the same patch.

> +    (arguments
> +     `(#:jar-name "doxia-sink-api.jar"
> +       #:source-dir "doxia-sink-api/src/main/java"
> +       #:tests? #f ; no tests
> +       #:phases (modify-phases %standard-phases
> +                  (replace 'install
> +                    (install-from-pom "doxia-sink-api/pom.xml")))))

That's correct :)
diff mbox series

Patch

From 84fca825656c44cdca93c1eb4647c9b380fc9ab3 Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 12 Jun 2022 21:42:33 +0300
Subject: [PATCH] gnu: Add maven-doxia-sink-api

* gnu/packages/maven.scm (maven-doxia-sink-api): New variable.
---
 gnu/packages/maven.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index 817fee1c71..c8338ca14b 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3887,3 +3888,37 @@  reports in two different file formats, plain text and xml.")))
     (description "This plugin provides the capability to build jars.  If you
 would like to sign jars please use the Maven Jarsigner Plugin instead.")
     (license license:asl2.0)))
+
+(define-public maven-doxia-sink-api
+  (package
+    (name "maven-doxia-sink-api")
+    (version "2.0.0-M2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitbox.apache.org/repos/asf/maven-doxia.git")
+                    (commit (string-append "doxia-" version))))
+              (file-name (git-file-name "doxia" version))
+              (sha256
+               (base32
+                "0jx96lg0hgjsrm8mynhac4hwh2hmgiwjpwpx2k03yr14040zcr48"))))
+    (build-system ant-build-system)
+    (native-inputs
+     (list java-javax-inject))
+    (propagated-inputs
+     (list maven-parent-pom-34))
+    (arguments
+     `(#:jar-name "doxia-sink-api.jar"
+       #:source-dir "doxia-sink-api/src/main/java"
+       #:tests? #f ; no tests
+       #:phases (modify-phases %standard-phases
+                  (replace 'install
+                    (install-from-pom "doxia-sink-api/pom.xml")))))
+    (home-page "https://maven.apache.org/doxia/index.html")
+    (synopsis "Generic markup language interface")
+    (description
+     "The @code{Sink} interface is a generic markup language
+interface provided as a Java API.  It contains several methods that
+encapsulate common text syntax.  A start tag is denoted by @code{xxxx()}
+method and a end of tag by @code{xxxx_()} method.")
+    (license license:asl2.0)))
-- 
2.25.1