diff mbox series

[bug#61338] gnu: Add labwc.

Message ID 87sffiuk8l.fsf@163.com
State New
Headers show
Series [bug#61338] gnu: Add labwc. | expand

Commit Message

Feng Shu Feb. 7, 2023, 5:18 a.m. UTC
From: Feng Shu <tumashu@163.com>

* gnu/packages/wm.scm (labwc): New variable.
---
 gnu/packages/wm.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 32aa5f39e5..ae9bf46623 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -109,6 +109,7 @@ 
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages fribidi)
   #:use-module (gnu packages gawk)
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gperf)
@@ -2712,6 +2713,48 @@  for wayland conceptually based on the X11 window manager
 @command{ratpoison}.")
     (license license:expat)))
 
+(define-public labwc
+  (package
+    (name "labwc")
+    (version "0.6.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/labwc/labwc")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0ap1d0p2fs3c4yj0v82hb3x4s5699wsf6a79sgnmpkw0nhsyvyrx"))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list pkg-config gettext-minimal))
+    (inputs
+     (list cairo
+           glib
+           libxcb
+           libxml2
+           pango
+           scdoc
+           wlroots))
+    (home-page "https://labwc.github.io")
+    (synopsis "Labwc is a wlroots-based window-stacking compositor for wayland")
+    (description
+     "Labwc is light-weight and independent with a focus on simply stacking
+windows well and rendering some window decorations, it is inspired by openbox.
+It takes a no-bling/frills approach and says no to features such as icons
+(except window buttons), animations, decorative gradients and any other
+options not required to reasonably render common themes.  It relies on clients
+for panels, screenshots, wallpapers and so on to create a full desktop
+environment.
+
+Labwc tries to stay in keeping with wlroots and sway in terms of general
+approach and coding style.
+
+Labwc has no reliance on any particular Desktop Environment, Desktop Shell or
+session.  Nor does it depend on any UI toolkits such as Qt or GTK.")
+    (license license:gpl2)))
+
 (define-public libucl
   (package
     (name "libucl")