diff mbox series

[bug#68070] gnu: python-flake8-isort: Update to 6.1.0.

Message ID 87sf3ncmxu.fsf@troyfigiel.com
State New
Headers show
Series [bug#68070] gnu: python-flake8-isort: Update to 6.1.0. | expand

Commit Message

Troy Figiel Dec. 27, 2023, 10:13 p.m. UTC
* gnu/packages/python-xyz.scm (python-flake8-isort): Update to 6.1.0.
[arguments]<#:phases>: Update check phase, because tests have been moved to run_tests.py.
[propagated-inputs]: Remove python-testfixtures.

Change-Id: Iecaf50021c8f29fb083f7a85b7ac731836e97384
---
 gnu/packages/python-xyz.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)


base-commit: 5bd80ccd69047b1777749e24d4adf2c951b5d14b

Comments

Mathieu Othacehe Dec. 28, 2023, 9:24 a.m. UTC | #1
> * gnu/packages/python-xyz.scm (python-flake8-isort): Update to 6.1.0.
> [arguments]<#:phases>: Update check phase, because tests have been moved to run_tests.py.
> [propagated-inputs]: Remove python-testfixtures.

Applied, thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cab44be011..85ce2256b8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13081,13 +13081,13 @@  (define-public python-flake8-todo
 (define-public python-flake8-isort
   (package
     (name "python-flake8-isort")
-    (version "4.1.1")
+    (version "6.1.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "flake8-isort" version))
         (sha256
-          (base32 "05r7z0j9rqgy0a9261bhisairrz6w8hy5hy5kf2mhvhfnx53056q"))))
+          (base32 "0gk4q504v42hdzpkndczc0kkwnr85jn1h5pvb561jh65p91r6qyl"))))
     (build-system python-build-system)
     (arguments
      (list
@@ -13096,8 +13096,8 @@  (define-public python-flake8-isort
           (replace 'check
             (lambda* (#:key tests? #:allow-other-keys)
               (when tests?
-                (invoke "pytest" "-vv")))))))
-    (propagated-inputs (list python-flake8 python-isort python-testfixtures))
+                (invoke "pytest" "-vv" "run_tests.py")))))))
+    (propagated-inputs (list python-flake8 python-isort))
     (native-inputs (list python-pytest))
     (home-page "https://github.com/gforcada/flake8-isort")
     (synopsis "Flake8 plugin integrating isort")