diff mbox series

[bug#69722] gnu: zig-zls: Update to 0.10.0

Message ID 87sf0x5on9.fsf@cock.li
State New
Headers show
Series [bug#69722] gnu: zig-zls: Update to 0.10.0 | expand

Commit Message

Justin Veilleux March 11, 2024, 5:22 a.m. UTC
Here is a patch to update zig-zls to a new version compatible with the
zig 0.10.0 compiler.
Cheers.

Comments

Christopher Baines March 13, 2024, 2:17 p.m. UTC | #1
Justin Veilleux <terramorpha@cock.li> writes:

> Here is a patch to update zig-zls to a new version compatible with the
> zig 0.10.0 compiler.
>
> [2. text/x-patch; 0001-gnu-zig-zls-Update-to-0.10.0.patch]...

Thanks! I've pushed this to master as
a00341c9e64c28dc05773b84179bedde103a001b.

Chris
diff mbox series

Patch

From 51b5c0a5293305b5c2606eecdf4b03eafaac700e Mon Sep 17 00:00:00 2001
Message-ID: <51b5c0a5293305b5c2606eecdf4b03eafaac700e.1710134409.git.terramorpha@cock.li>
From: terramorpha <terramorpha@cock.li>
Date: Mon, 11 Mar 2024 01:17:47 -0400
Subject: [PATCH] gnu: zig-zls: Update to 0.10.0

* gnu/packages/zig-xyz.scm (zig-zls): Update to 0.10.0 and use the zig-build-system.

Change-Id: Ie062067854ba1087b0394128c66e060df3ef5abf
---
 gnu/packages/zig-xyz.scm | 25 +++++++------------------
 1 file changed, 7 insertions(+), 18 deletions(-)

diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 200b5c9940..83a22f4fc1 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -2,6 +2,7 @@ 
 ;;; Copyright © 2022 Maya Tomasek <maya.tomasek@disroot.org>
 ;;; Copyright © 2023 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
+;;; Copyright © 2024 Justin Veilleux <terramorpha@cock.li>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -97,7 +98,7 @@  (define-public tigerbeetle
 (define-public zig-zls
   (package
     (name "zig-zls")
-    (version "0.9.0")
+    (version "0.10.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -107,24 +108,12 @@  (define-public zig-zls
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1hhs7dz9rpshfd1a7x5swmix2rmh53vsqskh3mzqlrj2lgb3cnii"))))
-    (build-system gnu-build-system)
-    (inputs (list zig-0.9 python))
+                "1lsks7h3z2m4psyn9mwdylv1d6a9i3z54ssadiz76w0clbh8ch9k"))))
+    (build-system zig-build-system)
+    (inputs (list zig-0.10 python))
     (arguments
-     (list #:phases #~(modify-phases %standard-phases
-                        (delete 'configure)
-                        (replace 'build
-                          (lambda* (#:key outputs #:allow-other-keys)
-                            (let ((out (assoc-ref outputs "out")))
-                              (setenv "ZIG_GLOBAL_CACHE_DIR"
-                                      (string-append (getcwd) "/zig-cache"))
-                              (invoke "zig" "build" "install"
-                                      "-Drelease-safe" "--prefix" out))))
-                        (delete 'install)
-                        (replace 'check
-                          (lambda* (#:key tests? #:allow-other-keys)
-                            (when tests?
-                              (invoke "zig" "build" "test")))))))
+     ;; The tests fail with memory leaks.
+     (list #:tests? #f))
     (synopsis "Zig language server")
     (description
      "Zig Language Server is a language server implementing the @acronym{LSP,

base-commit: a8196632647b343f8e03c8f12fbdc0cc84ff90f6
-- 
2.41.0